summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-03-10 03:13:36 -0600
committerLuis Martinez2021-03-10 03:13:36 -0600
commitd418f606e56161622014d32ff1e067cda83c928c (patch)
tree17f2454beddaed18366c312d0dcc3f95ca91e243
downloadaur-d418f606e56161622014d32ff1e067cda83c928c.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c39b0403e987
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = as-tree-git
+ pkgdesc = Print a list of paths as a tree of paths
+ pkgver = 0.12.0.r6.g0036c20
+ pkgrel = 1
+ url = https://github.com/jez/as-tree
+ arch = x86_64
+ license = custom:BOML
+ makedepends = git
+ makedepends = cargo
+ depends = gcc-libs
+ provides = as-tree
+ conflicts = as-tree
+ source = git+https://github.com/jez/as-tree
+ sha256sums = SKIP
+
+pkgname = as-tree-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d08ed6c5f9cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: lmartinez-mirror
+# Contributor: donbex <ap dot m at runbox dot com>
+pkgname=as-tree-git
+_pkgname=${pkgname%-git}
+pkgver=0.12.0.r6.g0036c20
+pkgrel=1
+pkgdesc="Print a list of paths as a tree of paths"
+arch=('x86_64')
+url="https://github.com/jez/as-tree"
+license=('custom:BOML')
+depends=('gcc-libs')
+makedepends=('git' 'cargo')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm 755 target/release/$_pkgname -t "$pkgdir/usr/bin"
+ install -Dm 644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}