summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett Cornwall2021-10-07 21:06:41 -0700
committerBrett Cornwall2021-10-07 21:06:41 -0700
commite70d886fb37e2911825b0caf961a3ab7d3b65f96 (patch)
tree79596aba4e19612dff0feaafe7804968785837d6
parent5b81e502956c7de148ccd84dc75e94433768ff70 (diff)
downloadaur-e70d886fb37e2911825b0caf961a3ab7d3b65f96.tar.gz
Remove plugin switches, only build asapconv
The plugins should be split up into separate AUR packages
-rw-r--r--PKGBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fdc138aed38..0aa232c75635 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,6 @@
# Maintainer: Brett Cornwall <ainola@archlinux.org>
# Contributor: nisk1
-# Uncomment any of below lines to build additional plugins:
-#_build_vlc="yes"
-#_build_moc="yes"
-#_build_xmms="yes"
-
pkgname=asap
pkgver=4.0.0
pkgrel=2
@@ -18,54 +13,12 @@ options=(staticlibs)
source=("http://downloads.sourceforge.net/asap/${pkgname}-${pkgver}.tar.gz")
sha256sums=('7612dc0251c13345bd17dbec46cdecd794a50cab5d4b7840471a6bed41933640')
-if [[ "$_build_vlc" = "yes" ]]; then
- makedepends+=('vlc')
-fi
-
-if [[ "$_build_moc" = "yes" ]]; then
- makedepends+=('moc')
- source+=('http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.2.tar.bz2')
- sha256sums+=('f3a68115602a4788b7cfa9bbe9397a9d5e24c68cb61a57695d1c2c3ecf49db08')
-fi
-
-if [[ "$_build_xmms" = "yes" ]]; then
- makedepends+=('xmms')
-fi
-
build() {
cd $srcdir/$pkgname-$pkgver/
make
-
- if [[ "$_build_vlc" = "yes" ]]; then
- make asap-vlc
- fi
-
- if [[ "$_build_xmms" = "yes" ]]; then
- make asap-xmms
- fi
-
- if [[ "$_build_moc" = "yes" ]]; then
- cd $srcdir/moc-2.5.2
- ./configure
- cd $srcdir/$pkgname-$pkgver/
- make asap-moc MOC_INCLUDE="$srcdir/moc-2.5.2/"
- fi
}
package() {
cd $srcdir/$pkgname-$pkgver/
make DESTDIR="${pkgdir}" prefix="/usr" install-asapconv install
-
- if [[ "$_build_vlc" = "yes" ]]; then
- make DESTDIR="${pkgdir}" prefix="/usr" install-vlc
- fi
-
- if [[ "$_build_xmms" = "yes" ]]; then
- make DESTDIR="${pkgdir}" prefix="/usr" install-xmms
- fi
-
- if [[ "$_build_moc" = "yes" ]]; then
- make MOC_PLUGIN_DIR="${pkgdir}/usr/lib/moc/decoder_plugins" install-moc
- fi
}
-