summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2014-05-08 11:52:48 +0800
committerAllen Zhong2014-05-08 11:52:48 +0800
commite67fc952160a3a70a21476bf37c0824ba419a18e (patch)
tree1ca6088df6c816b764ec0417ae476726d7ffc380
parent774a44ea6ec9099df24f9d40e88c4727f8f37586 (diff)
downloadaur-e67fc952160a3a70a21476bf37c0824ba419a18e.tar.gz
upgpkg: asar-apache
* Change apache.mmap path to httpd's log dir + asar_apache_gather
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20fc947666b1..6b9f652c9617 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
# Maintainer: Allen Zhong <moeallenz@gmail.com>
pkgname=asar-apache
pkgver=r40
-pkgrel=1
+pkgrel=2
pkgdesc="A System Activity Reporter of apache httpd"
arch=(i686 x86_64)
url="http://code.google.com/p/python-asar/"
license=('GPL2')
depends=('apache')
-source=("http://python-asar.googlecode.com/svn-history/$pkgver/trunk/asar-apache-agent/asar_apache_agent.c")
-md5sums=('ae8af0c209828408496c8a09adf51102')
+source=("http://python-asar.googlecode.com/svn-history/$pkgver/trunk/asar-apache-agent/asar_apache_agent.c"
+ "http://python-asar.googlecode.com/svn-history/$pkgver/trunk/asar-apache-agent/asar_apache_gather.c")
+md5sums=('ae8af0c209828408496c8a09adf51102'
+ '5fdf7a14172fb6ed70c707231e57c359')
build() {
cd "$srcdir"
+ sed -i 's/\/tmp/\/var\/log\/httpd/g' *.c
gcc -o asar_apache_agent asar_apache_agent.c
+ gcc -o asar_apache_gather asar_apache_gather.c
}
package() {
cd "$srcdir"
install -d "$pkgdir"/usr/sbin
install -Dm755 asar_apache_agent "$pkgdir"/usr/sbin/
+ install -Dm755 asar_apache_gather "$pkgdir"/usr/sbin/
}