aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllan Niles2023-09-12 22:19:53 -0600
committerAllan Niles2023-09-12 22:19:53 -0600
commitb37ff9d09abc1a1813805c829c88e1d94272f291 (patch)
tree169205e2443f846e66ad209e956053af738d827d
downloadaur-b37ff9d09abc1a1813805c829c88e1d94272f291.tar.gz
add package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27cac18b1709
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ascii-battleship
+ pkgdesc = An ASCII Battleship game built in Java that can be played in the terminal.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/allancoding/ascii-battleship
+ arch = any
+ license = Apache-2.0
+ depends = java-runtime
+ source = https://github.com/allancoding/ascii-battleship/raw/main/Ascii_Battleship.jar
+ sha256sums = 77d350710fe8cebeb15572713fe0c016ac42da13cee1ca4d5d0f915cdb4f2fe8
+
+pkgname = ascii-battleship
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bd33df460db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=ascii-battleship
+pkgver=1.0
+pkgrel=1
+pkgdesc="An ASCII Battleship game built in Java that can be played in the terminal."
+url="https://github.com/allancoding/ascii-battleship"
+license=('Apache-2.0')
+depends=('java-runtime')
+arch=('any')
+source=("https://github.com/allancoding/ascii-battleship/raw/main/Ascii_Battleship.jar")
+sha256sums=('77d350710fe8cebeb15572713fe0c016ac42da13cee1ca4d5d0f915cdb4f2fe8')
+package() {
+ install -d "${pkgdir}/usr/share/java/${pkgname}"
+ install -Dm644 "${srcdir}/Ascii_Battleship.jar" "${pkgdir}/usr/share/java/${pkgname}/Ascii_Battleship.jar"
+ echo "#!/bin/sh" > "${srcdir}/ascii-battleship.sh"
+ echo "java -jar /usr/share/java/${pkgname}/Ascii_Battleship.jar" >> "${srcdir}/ascii-battleship.sh"
+ chmod +x "${srcdir}/ascii-battleship.sh"
+ install -Dm755 "${srcdir}/ascii-battleship.sh" "${pkgdir}/usr/bin/ascii-battleship"
+}