summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormagnus2021-09-03 18:58:36 -0500
committermagnus2021-09-03 18:58:36 -0500
commit4060e0cfae91dbfe6fe49186d38d743b9bea0ca3 (patch)
tree0582aa9bb7d67d7d47c650979a0c71153245ae03
downloadaur-4060e0cfae91dbfe6fe49186d38d743b9bea0ca3.tar.gz
Add ascii-image-converter-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46e0ab50caef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ascii-image-converter-git
+ pkgdesc = A cross-platform command-line tool to convert images into ascii art and print them on the console.
+ pkgver = 1.7.1
+ pkgrel = 2
+ url = https://github.com/TheZoraiz/ascii-image-converter
+ arch = any
+ license = GPL
+ makedepends = go
+ provides = ascii-image-converter
+ conflicts = ascii-image-converter
+ source = git+https://github.com/TheZoraiz/ascii-image-converter.git
+ md5sums = SKIP
+
+pkgname = ascii-image-converter-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..076731569061
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Magnus Anderson <magnus@iastate.edu>
+pkgname=ascii-image-converter-git
+pkgver=1.7.1
+pkgrel=2
+pkgdesc="A cross-platform command-line tool to convert images into ascii art and print them on the console."
+arch=('any')
+url="https://github.com/TheZoraiz/ascii-image-converter"
+license=('custom:ApacheV2')
+# I'm not sure if it depends on any other libraries, I think Go takes care of it
+makedepends=('go')
+provides=('ascii-image-converter')
+conflicts=('ascii-image-converter')
+source=("git+https://github.com/TheZoraiz/ascii-image-converter.git")
+md5sums=('SKIP')
+
+build() {
+ cd "ascii-image-converter"
+ go build
+}
+package() {
+ cd "ascii-image-converter"
+ install -Dm 755 ./ascii-image-converter -t "$pkgdir/usr/bin/"
+ install -Dm 644 ./LICENSE.txt -t "$pkgdir/usr/share/licenses/ascii-image-converter/"
+}