summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Julien-Neitzert2023-10-28 01:52:09 -0700
committerDaniel Julien-Neitzert2023-10-28 01:52:09 -0700
commit18b779b7f4b0deae9363a78ef903577fb0e82901 (patch)
tree5b3cf2acbf8dd7d593c687a76e4d9ae3dccb9cd9
downloadaur-18b779b7f4b0deae9363a78ef903577fb0e82901.tar.gz
initialized package
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD26
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1c09943f0da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ascii-pony-git
+ pkgdesc = Shows a pony and system information
+ pkgver = 20220221
+ pkgrel = 1
+ url = https://gitlab.com/mattia.basaglia/ASCII-Pony
+ arch = any
+ license = GPLv3+
+ license = CC-BY-SA 3.0
+ depends = bash
+ depends = coreutils
+ depends = iproute2
+ depends = inetutils
+ depends = procps-ng
+ depends = lsb-release
+ depends = sed
+ depends = grep
+ depends = findutils
+ depends = awk
+ depends = lxc
+ depends = sysfsutils
+ depends = bc
+ provides = systempony
+ source = git+https://gitlab.com/mattia.basaglia/ASCII-Pony.git
+ sha256sums = SKIP
+
+pkgname = ascii-pony-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..054dd976a76e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Daniel Julien-Neitzert <danieljulneit@gmail.com>
+
+pkgname=ascii-pony-git
+_gitname=ASCII-Pony
+pkgrel=1
+pkgdesc='Shows a pony and system information'
+pkgver=20220221
+arch=('any')
+url='https://gitlab.com/mattia.basaglia/ASCII-Pony'
+source=('git+https://gitlab.com/mattia.basaglia/ASCII-Pony.git')
+provides=('systempony')
+license=('GPLv3+' 'CC-BY-SA 3.0')
+depends=('bash' 'coreutils' 'iproute2' 'inetutils' 'procps-ng'
+ 'lsb-release' 'sed' 'grep' 'findutils' 'awk' 'lxc'
+ 'sysfsutils' 'bc')
+sha256sums=('SKIP')
+
+package() {
+ cd $_gitname
+ make install PREFIX="$pkgdir/usr/local"
+}
+
+pkgver() {
+ cd $_gitname
+ git log -1 --format="%cd" --date=short | sed 's/-//g'
+}