summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:09:06 +0100
committerSteven Honeyman2015-06-09 19:09:06 +0100
commit207d1ce530a990119b9d19da13a18dc15e2072c4 (patch)
treed3de1ad355cb5ea68042688f5a5a4277bda64f9a
downloadaur-207d1ce530a990119b9d19da13a18dc15e2072c4.tar.gz
Initial import
-rw-r--r--.AURINFO12
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
3 files changed, 45 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..6155bb296b20
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,12 @@
+pkgbase = asciidoc-fake
+ pkgdesc = A fake asciidoc to keep some packages happy, and save disk space
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.methods.co.nz/asciidoc
+ arch = any
+ license = GPL
+ provides = asciidoc
+ conflicts = asciidoc
+
+pkgname = asciidoc-fake
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6155bb296b20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = asciidoc-fake
+ pkgdesc = A fake asciidoc to keep some packages happy, and save disk space
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.methods.co.nz/asciidoc
+ arch = any
+ license = GPL
+ provides = asciidoc
+ conflicts = asciidoc
+
+pkgname = asciidoc-fake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fa729d27629
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# A dummy package, to save disk space.
+# The symlink is to prevent "command not found" when installing packages that need a2x + asciidoc
+#
+# WARNING: Only install this if you know what you are doing & why!
+#
+
+pkgname=asciidoc-fake
+pkgver=1.0
+pkgrel=1
+pkgdesc="A fake asciidoc to keep some packages happy, and save disk space"
+arch=('any')
+url="http://www.methods.co.nz/asciidoc"
+license=('GPL')
+conflicts=('asciidoc')
+provides=('asciidoc')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s /usr/bin/true "$pkgdir/usr/bin/a2x"
+ ln -s /usr/bin/true "$pkgdir/usr/bin/asciidoc"
+}