summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2016-01-23 12:50:19 +0200
committerChristoph Gysin2016-01-23 12:51:32 +0200
commitb9f34f8f13434e6c1ac8675a86f19f7dc3013e53 (patch)
tree657d22f76b5aa81892bfc103f4317b97db3886db
downloadaur-b9f34f8f13434e6c1ac8675a86f19f7dc3013e53.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD61
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae0b468147bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sat Jan 23 10:48:00 UTC 2016
+pkgbase = asciidoc-git
+ pkgdesc = Text document format for short documents, articles, books and UNIX man pages.
+ pkgver = 1
+ pkgrel = 1
+ url = git+http://www.methods.co.nz/asciidoc/
+ arch = any
+ license = GPL
+ depends = python2
+ depends = libxslt
+ depends = docbook-xsl
+ optdepends = lilypond: music-filter
+ optdepends = imagemagick: music-filter (used in conjunction with lilypond)
+ optdepends = source-highlight: source-highlight-filter
+ optdepends = dblatex: pdf generation
+ optdepends = fop: alternative pdf generation
+ optdepends = lynx: text generation
+ optdepends = w3m: text generation (alternative to lynx)
+ provides = asciidoc
+ conflicts = asciidoc
+ source = git+https://github.com/asciidoc/asciidoc.git
+ sha1sums = SKIP
+
+pkgname = asciidoc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fe3e45aa93db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/asciidoc
+/*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31efb51f4440
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+
+pkgname=asciidoc-git
+_pkgname=asciidoc
+pkgver=8.6.9.84.gd919c61
+pkgrel=1
+pkgdesc='Text document format for short documents, articles, books and UNIX man pages.'
+arch=('any')
+url='git+http://www.methods.co.nz/asciidoc/'
+license=('GPL')
+depends=('python2' 'libxslt' 'docbook-xsl')
+provides=('asciidoc')
+conflicts=('asciidoc')
+optdepends=('lilypond: music-filter'
+ 'imagemagick: music-filter (used in conjunction with lilypond)'
+ 'source-highlight: source-highlight-filter'
+ 'dblatex: pdf generation'
+ 'fop: alternative pdf generation'
+ 'lynx: text generation'
+ 'w3m: text generation (alternative to lynx)')
+source=('git+https://github.com/asciidoc/asciidoc.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/./g;s/^v//'
+}
+
+prepare() {
+ cd $_pkgname
+
+ # python2 fix
+ sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' \
+ a2x.py \
+ asciidoc.py \
+ asciidocapi.py \
+ filters/code/code-filter.py \
+ filters/graphviz/graphviz2png.py \
+ filters/latex/latex2img.py \
+ filters/music/music2png.py
+ sed -i 's_python a2x.py_./a2x.py_' \
+ Makefile.in
+}
+
+build() {
+ cd $_pkgname
+
+ autoconf -i
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+}
+
+package() {
+ cd $_pkgname
+
+ make install DESTDIR=$pkgdir
+
+ install -Dm644 asciidocapi.py \
+ $pkgdir/usr/lib/python2.7/site-packages/asciidocapi.py
+}