summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-11-06 11:06:31 +0800
committertaotieren2021-11-06 11:06:31 +0800
commit256606c1f3188e88afb98971a662efe39ef8361d (patch)
tree44ea43538968862df854d539eaeac28bb930be3a
downloadaur-256606c1f3188e88afb98971a662efe39ef8361d.tar.gz
Update asciidoctor-web-pdf-git
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD37
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98da699147c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = asciidoctor-web-pdf-git
+ pkgdesc = A PDF converter for AsciiDoc based on web technologies. It allows complex layouts to be defined with CSS and JavaScript, while writing the content in AsciiDoc.
+ pkgver = v1.0.0.alpha.12.r100.ga5421d1
+ pkgrel = 1
+ url = https://github.com/Mogztter/asciidoctor-web-pdf
+ arch = any
+ license = MIT
+ depends = npm
+ depends = poppler
+ depends = ghostscript
+ provides = asciidoctor-web-pdf-git
+ conflicts = asciidoctor-web-pdf-git
+ conflicts = asciidoctor-web-pdf
+ conflicts = asciidoctor-pdf
+ options = !strip
+ source = asciidoctor-web-pdf::git+https://github.com/Mogztter/asciidoctor-web-pdf.git
+ sha256sums = SKIP
+
+pkgname = asciidoctor-web-pdf-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37bb465dc2db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01758b31d13c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=asciidoctor-web-pdf-git
+pkgver=v1.0.0.alpha.12.r100.ga5421d1
+pkgrel=1
+pkgdesc="A PDF converter for AsciiDoc based on web technologies. It allows complex layouts to be defined with CSS and JavaScript, while writing the content in AsciiDoc."
+arch=('any')
+url="https://github.com/Mogztter/asciidoctor-web-pdf"
+license=('MIT')
+provides=(${pkgname})
+conflicts=(${pkgname} ${pkgname%-git} asciidoctor-pdf)
+#replaces=(${pkgname})
+depends=('npm' 'poppler' 'ghostscript')
+makedepends=()
+backup=()
+options=('!strip')
+#install=${pkgname}.install
+source=("${pkgname%-git}::git+${url}.git")
+sha256sums=('SKIP')
+#noextract=("${pkgname}-${_pkgver}.tar.gz")
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ npm install -g --prefix "${pkgdir}/usr" "${srcdir}/${pkgname%-git}"
+
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/cli/issues/1103 for details.
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
+}