summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-16 07:11:33 +0200
committerDimitris Kiziridis2020-03-16 07:11:33 +0200
commit2fec9570432501f2e2fdcbb5ec5334cc51283042 (patch)
treeda370b2c90e3c21486dd21a2a0a303adb2522e26
parentd8b06881da62189940f204c1024dc0240b1fb9f4 (diff)
downloadaur-2fec9570432501f2e2fdcbb5ec5334cc51283042.tar.gz
bugfix in PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 3 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 157ab54230ae..d82f40789449 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = asciigraph
pkgdesc = Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with no other dependencies
pkgver = 0.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/guptarohit/asciigraph
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index fbcbe59f2fde..5fdde631a128 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=asciigraph
pkgver=0.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with no other dependencies"
arch=('x86_64')
url='https://github.com/guptarohit/asciigraph'
@@ -11,15 +11,12 @@ makedepends=('go')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/guptarohit/asciigraph/archive/v0.4.1.tar.gz")
md5sums=('6efaf8b04f7f55e4863ce3127aa2308c')
-prepare() {
+build() {
cd "${srcdir}/${pkgname}-${pkgver}"
mkdir -p $srcdir/go
export GOPATH="${srcdir}"/go
export PATH=$PATH:$GOPATH/bin
go get -d -v ./...
-}
-
-build() {
cd "${srcdir}/${pkgname}-${pkgver}/cmd/asciigraph"
go build -v -o "${srcdir}/asciigraph-bin"
}