summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2019-12-09 12:08:07 +0100
committerFrederic Bezies2019-12-09 12:08:07 +0100
commit42b08cee7abc2215f0067f411511f77040344fe8 (patch)
tree86d5ebb637142301e9ae138cc058d06abd962c23
parent27c986a5d106727bb59872dba9750fff77c6e434 (diff)
downloadaur-42b08cee7abc2215f0067f411511f77040344fe8.tar.gz
updated PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
2 files changed, 13 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0f4680b75f7..acad1b0fd6ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = asciinema-git
pkgdesc = Record and share your terminal sessions, the right way
- pkgver = 1.0.0.r8.g365b36c
- pkgrel = 2
- url = https://github.com/sickill/asciinema
+ pkgver = 2.0.0.r67.g350d5e9
+ pkgrel = 1
+ url = https://github.com/asciinema/asciinema
arch = any
license = MIT
makedepends = git
- makedepends = gcc-go
+ makedepends = python
conflicts = asciinema
- source = asciinema-git::git+https://github.com/sickill/asciinema.git
+ source = asciinema-git::git+https://github.com/asciinema/asciinema.git
sha256sums = SKIP
pkgname = asciinema-git
diff --git a/PKGBUILD b/PKGBUILD
index dd64f71e7338..91e400df4217 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,29 @@
-# Maintainer: sudokode <sudokode@gmail.com>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: sudokode <sudokode@gmail.com>
# Contributor: Marcin Kulik <m@kulik.com>
name=asciinema
pkgname=asciinema-git
-pkgver=1.0.0.r8.g365b36c
-pkgrel=2
+pkgver=2.0.0.r67.g350d5e9
+pkgrel=1
pkgdesc="Record and share your terminal sessions, the right way"
arch=('any')
-url="https://github.com/sickill/$name"
+url="https://github.com/asciinema/$name"
license=('MIT')
-makedepends=('git' 'gcc-go')
+makedepends=('git' 'python')
conflicts=("$name")
-source=("$pkgname::git+https://github.com/sickill/${name}.git")
+source=("$pkgname::git+https://github.com/asciinema/${name}.git")
sha256sums=('SKIP')
pkgver() {
cd $pkgname
-
git describe --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
}
-prepare() {
- cd $pkgname
-
- GOPATH="$srcdir" go get -v -d
-}
-
-build() {
- cd $pkgname
-
- GOPATH="$srcdir" make build
-}
-
package() {
cd $pkgname
- make DESTDIR="$pkgdir" install
+ python setup.py install --root="$pkgdir/" install
}
# vim:set ts=2 sw=2 et: