summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 04:03:18 -0600
committerBrian Bidulock2015-06-10 04:03:18 -0600
commit68e0a61119983cc7622d97b7212af52e66512188 (patch)
tree061d91cf734970889d5eb812744011bc7818c493
downloadaur-68e0a61119983cc7622d97b7212af52e66512188.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD60
-rw-r--r--asclock.desktop43
3 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bca4fd566165
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = asclock-xlib
+ pkgdesc = The AfterStep clock dock app - Xlib version
+ pkgver = 2.0.12
+ pkgrel = 5
+ url = http://www.cs.mun.ca/~gstarkes/wmaker/dockapps/time.html#asclock
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxpm
+ provides = asclock
+ conflicts = asclock
+ conflicts = asclock-gtk
+ source = http://gentoo.osuosl.org/distfiles/asclock-2.0.12.tar.gz
+ source = asclock.desktop
+ md5sums = 99cb6491358bb0044e9b75b2e06b043b
+ md5sums = 54149bbbef522b2bc5d5e65ef76f4cbd
+
+pkgname = asclock-xlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19b1e27d1467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgname=asclock-xlib
+_pkgname=asclock
+pkgver=2.0.12
+pkgrel=5
+pkgdesc="The AfterStep clock dock app - Xlib version"
+url="http://www.cs.mun.ca/~gstarkes/wmaker/dockapps/time.html#asclock"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libxpm')
+provides=('asclock')
+conflicts=('asclock' 'asclock-gtk')
+source=("http://gentoo.osuosl.org/distfiles/$_pkgname-$pkgver.tar.gz"
+ "asclock.desktop")
+md5sums=('99cb6491358bb0044e9b75b2e06b043b'
+ '54149bbbef522b2bc5d5e65ef76f4cbd')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ rm -fr default_theme
+ mkdir default_theme
+ cd default_theme
+ cp -s ../themes/classic/* .
+ rm -f month.xpm
+ cp -s ../languages/english/month.xpm .
+ for f in *.xpm ; do
+ sed -e 's,^static ,,' -i $f
+ done
+ cd ..
+ sed -e 's,share/asclock/,share/asclock/themes/,' -i config.c
+ xmkmf
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make clean
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install install.man
+ install -d "$pkgdir/usr/share/asclock/themes"
+ install -d "$pkgdir/usr/share/asclock/themes/Newstone"
+ install -t "$pkgdir/usr/share/asclock/themes/Newstone" themes/Newstone/*
+ install -d "$pkgdir/usr/share/asclock/themes/Orb"
+ install -t "$pkgdir/usr/share/asclock/themes/Orb" themes/Orb/*
+ install -d "$pkgdir/usr/share/asclock/themes/Stone"
+ install -t "$pkgdir/usr/share/asclock/themes/Stone" themes/Stone/*
+ install -d "$pkgdir/usr/share/asclock/themes/beats"
+ install -t "$pkgdir/usr/share/asclock/themes/beats" themes/beats/*
+ install -d "$pkgdir/usr/share/asclock/themes/classic"
+ install -t "$pkgdir/usr/share/asclock/themes/classic" themes/classic/*
+ install -d "$pkgdir/usr/share/asclock/themes/shaped"
+ install -t "$pkgdir/usr/share/asclock/themes/shaped" themes/shaped/*
+ install -Dm0644 "$srcdir/asclock.desktop" \
+ "$pkgdir/usr/share/applications/asclock.desktop"
+}
+
+# vim: set sw=2 et:
diff --git a/asclock.desktop b/asclock.desktop
new file mode 100644
index 000000000000..00968c24288e
--- /dev/null
+++ b/asclock.desktop
@@ -0,0 +1,43 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=ASClock
+GenericName=Clock
+Comment=The AfterStep clock dock app
+TryExec=asclock
+Exec=asclock -d -t shaped
+Icon=GNUstep3D
+Terminal=false
+StartupNotify=false
+Categories=DockApp;WMAKER;
+StartupWMClass=asclock
+X-Arch-Package=asclock-xlib
+Actions=Newstone;Orb;Stone;Analog;Beats;Classic;Shaped;
+
+[Desktop Action Newstone]
+Name=Newstone theme
+Exec=asclock -d -t Newstone
+
+[Desktop Action Orb]
+Name=Orb theme
+Exec=asclock -d -t Orb
+
+[Desktop Action Stone]
+Name=Stone theme
+Exec=asclock -d -t Stone
+
+[Desktop Action Analog]
+Name=Analog theme
+Exec=asclock -d -t analog
+
+[Desktop Action Beats]
+Name=Beats theme
+Exec=asclock -d -t beats
+
+[Desktop Action Classic]
+Name=Classic theme
+Exec=asclock -d -t classic
+
+[Desktop Action Shaped]
+Name=Shaped theme
+Exec=asclock -d -t shaped