summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorianux2015-06-10 13:02:05 +0200
committerianux2015-06-10 13:02:05 +0200
commit11bbd73bc12d07e47dd6f1b12c0f08e5eda9b970 (patch)
tree1c0fa7e39990793783ee30d2006c840b0e8e2645
downloadaur-11bbd73bc12d07e47dd6f1b12c0f08e5eda9b970.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..373894aa8c2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = asdcplib
+ pkgdesc = open source implementation of SMPTE and the MXF Interop “Sound & Picture Track File” format
+ pkgver = 1.12.60
+ pkgrel = 1
+ url = http://www.cinecert.com/asdcplib/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = expat
+ depends = openssl
+ source = http://download.cinecert.com/asdcplib/asdcplib-1.12.60.tar.gz
+ sha1sums = 427268c3070827af63e067ff4d87aa32fe26ac1d
+
+pkgname = asdcplib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f47f2cdd876
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: ianux <ianux@free.fr>
+
+pkgname=asdcplib
+pkgver=1.12.60
+pkgrel=1
+pkgdesc="open source implementation of SMPTE and the MXF Interop “Sound & Picture Track File” format"
+arch=('i686' 'x86_64')
+url="http://www.cinecert.com/asdcplib/"
+license=('GPL3')
+depends=('expat' 'openssl')
+source=(http://download.cinecert.com/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+sha1sums=('427268c3070827af63e067ff4d87aa32fe26ac1d')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+