summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfriehmaen2016-06-03 18:45:50 +0200
committerfriehmaen2016-06-03 18:45:50 +0200
commit1f1b3069c002c62ffdb335aa8ce46be70918d5fd (patch)
tree326ba7cea18cec0756046dbb76a0aaf2ec7dd7e4
parent4e79c20cdf323ea5e10cdaaba3f834e9fba89af3 (diff)
downloadaur-1f1b3069c002c62ffdb335aa8ce46be70918d5fd.tar.gz
-Enabled support for subtitle files (requires expat)
-Build of expat seems to be incompatible with "--as-needed"
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8a4fb87614c..9c718871d53d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = asdcplib2
pkgdesc = open source implementation of SMPTE and the MXF Interop “Sound & Picture Track File” format with IMF support
pkgver = 2.5.14
- pkgrel = 1
+ pkgrel = 2
url = http://www.cinecert.com/asdcplib/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 853dc82525b6..349e9fdf845a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,38 @@
# Contributor: ianux <ianux@free.fr>
pkgname=asdcplib2
+_pkgname=asdcplib
pkgver=2.5.14
-pkgrel=1
+pkgrel=2
pkgdesc="open source implementation of SMPTE and the MXF Interop “Sound & Picture Track File” format with IMF support"
arch=('i686' 'x86_64')
url="http://www.cinecert.com/asdcplib/"
license=('custom')
depends=('expat' 'openssl')
-source=(http://download.cinecert.com/asdcplib/asdcplib-${pkgver}.tar.gz)
+source=("http://download.cinecert.com/asdcplib/${_pkgname}-${pkgver}.tar.gz")
sha1sums=('23b9b459203d89d24ff0e6fceadc3b2bd6a6ff3b')
md5sums=('f84a4b30c6e8aca234e8327c99e6f512')
+prepare() {
+ # --as-needed seems to break compatibility with libexpat, and configure step does not detect libexpat
+ export LDFLAGS="${LDFLAGS//--as-needed,}"
+}
+
build() {
- cd asdcplib-${pkgver}
- ./configure --prefix=/usr --enable-as-02
- make
+ cd ${_pkgname}-${pkgver}
+
+ # expat is required to open subtitle files
+ ./configure --prefix=/usr --enable-as-02 --with-expat
+ make
}
package() {
- cd asdcplib-${pkgver}
- make DESTDIR=${pkgdir} install
+ cd ${_pkgname}-${pkgver}
+
+ make DESTDIR=${pkgdir} install
- #copy license file
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ #copy license file
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}