summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTHS2016-11-20 11:29:54 +0100
committerTHS2016-11-20 11:29:54 +0100
commit18cf281c527c424063bbe938650575581abd9311 (patch)
tree1a42c00739ce5804ed33a50c86aa37a791942f44
parent7e7a66ff69fed609330c30b1a8b57cc32e9ca762 (diff)
downloadaur-18cf281c527c424063bbe938650575581abd9311.tar.gz
fix icons and include share, doc, lib
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD36
2 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41fb5edd3b73..7911571fbe90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aseba-git
pkgdesc = A set of tools which allow beginners to program robots easily and efficiently.
- pkgver = 1.5.3.r93.gc4a75de
+ pkgver = 1.5.3.r102.g8ccdc9d
pkgrel = 1
url = https://github.com/aseba-community/aseba
install = aseba-git.install
@@ -16,6 +16,7 @@ pkgbase = aseba-git
depends = sdl2
depends = protobuf
depends = qtwebkit
+ depends = avahi
provides = aseba
source = dashel::git+https://github.com/aseba-community/dashel.git
source = enki::git+https://github.com/enki-community/enki.git
diff --git a/PKGBUILD b/PKGBUILD
index f2289e1afe12..587540d2a39a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: THS <mail@thson.de>
pkgname=aseba-git
-pkgver=1.5.3.r93.gc4a75de
+pkgver=1.5.3.r102.g8ccdc9d
pkgrel=1
pkgdesc="A set of tools which allow beginners to program robots easily and efficiently."
arch=('x86_64')
url="https://github.com/aseba-community/aseba"
license=('LGPL3')
provides=('aseba')
-depends=('boost' 'qt4' 'qt5-tools' 'qwt' 'libgudev' 'libxml2' 'python2' 'sdl2' 'protobuf' 'qtwebkit')
+depends=('boost' 'qt4' 'qt5-tools' 'qwt' 'libgudev' 'libxml2' 'python2' 'sdl2' 'protobuf' 'qtwebkit' 'avahi')
install="aseba-git.install"
source=('dashel::git+https://github.com/aseba-community/dashel.git'
'enki::git+https://github.com/enki-community/enki.git'
@@ -42,13 +42,18 @@ cd build-enki
cmake ../enki -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python2 #Only Python2 works
make
cd ..
-cd aseba
+cd build-aseba
export dashel_DIR=../build-dashel
-cmake ../aseba -DCMAKE_BUILD_TYPE=RelWithDebInfo -Ddashel_DIR=../build-dashel -DDASHEL_INCLUDE_DIR=../dashel -DDASHEL_LIBRARY=../build-dashel/libdashel.a -DENKI_INCLUDE_DIR=../enki -DENKI_LIBRARY=../build-enki/enki/libenki.a -DENKI_VIEWER_LIBRARY=../build-enki/viewer/libenkiviewer.a
+cmake ../aseba -DCMAKE_BUILD_TYPE=RelWithDebInfo -Ddashel_DIR=../build-dashel -DDASHEL_INCLUDE_DIR=../dashel -DDASHEL_LIBRARY=../build-dashel/libdashel.a -DENKI_INCLUDE_DIR=../enki -DENKI_LIBRARY=../build-enki/enki/libenki.a -DENKI_VIEWER_LIBRARY=../build-enki/viewer/libenkiviewer.a -DCMAKE_INSTALL_PREFIX=/usr
+
make
}
package() {
+ cd $srcdir/build-aseba
+
+ make DESTDIR=$pkgdir install
+
install -Dm755 "${srcdir}/aseba/menu/freedesktop/asebachallenge.desktop" "${pkgdir}/usr/share/applications/asebachallenge.desktop"
install -Dm755 "${srcdir}/aseba/menu/freedesktop/asebaonlinehelp.desktop" "${pkgdir}/usr/share/applications/asebaonlinehelp.desktop"
install -Dm755 "${srcdir}/aseba/menu/freedesktop/asebaplayground.desktop" "${pkgdir}/usr/share/applications/asebaplayground.desktop"
@@ -57,23 +62,8 @@ package() {
install -Dm755 "${srcdir}/aseba/menu/freedesktop/thymioupgrader.desktop" "${pkgdir}/usr/share/applications/thymioupgrader.desktop"
install -Dm755 "${srcdir}/aseba/menu/freedesktop/thymiovpl.desktop" "${pkgdir}/usr/share/applications/thymiovpl.desktop"
install -Dm755 "${srcdir}/aseba/menu/freedesktop/thymiownetconfig.desktop" "${pkgdir}/usr/share/applications/thymiownetconfig.desktop"
- install -Dm755 ${srcdir}/aseba/menu/freedesktop/48x48/* -t ${pkgdir}/usr/share/icons/hicolor/48x48/
- install -Dm755 "${srcdir}/aseba/clients/studio/thymiovpl" "${pkgdir}/usr/bin/thymiovpl"
- install -Dm755 "${srcdir}/aseba/clients/studio/asebastudio" "${pkgdir}/usr/bin/asebastudio"
- install -Dm755 "${srcdir}/aseba/targets/playground/asebaplayground" "${pkgdir}/usr/bin/asebaplayground"
- install -Dm755 "${srcdir}/aseba/targets/challenge/asebachallenge" "${pkgdir}/usr/bin/asebachallenge"
- install -Dm755 "${srcdir}/aseba/clients/thymioupgrader/thymioupgrader" "${pkgdir}/usr/bin/thymioupgrader"
- install -Dm755 "${srcdir}/aseba/clients/thymiownetconfig/thymiownetconfig" "${pkgdir}/usr/bin/thymiownetconfig"
- install -Dm755 "${srcdir}/aseba/clients/cmd/asebacmd" "${pkgdir}/usr/bin/asebacmd"
- install -Dm755 "${srcdir}/aseba/clients/dump/asebadump" "${pkgdir}/usr/bin/asebadump"
- install -Dm755 "${srcdir}/aseba/clients/exec/asebaexec" "${pkgdir}/usr/bin/asebaexec"
- install -Dm755 "${srcdir}/aseba/clients/joy/asebajoy" "${pkgdir}/usr/bin/asebajoy"
- install -Dm755 "${srcdir}/aseba/clients/dump/asebadump" "${pkgdir}/usr/bin/asebadump"
- install -Dm755 "${srcdir}/aseba/clients/massloader/asebamassloader" "${pkgdir}/usr/bin/asebamassloader"
- install -Dm755 "${srcdir}/aseba/clients/replay/asebaplay" "${pkgdir}/usr/bin/asebaplay"
- install -Dm755 "${srcdir}/aseba/clients/replay/asebarec" "${pkgdir}/usr/bin/asebarec"
- install -Dm755 "${srcdir}/aseba/switches/http/asebahttp" "${pkgdir}/usr/bin/asebahttp"
- install -Dm755 "${srcdir}/aseba/switches/http2/asebahttp2" "${pkgdir}/usr/bin/asebahttp2"
- install -Dm755 "${srcdir}/aseba/switches/medulla/asebamedulla" "${pkgdir}/usr/bin/asebamedulla"
- install -Dm755 "${srcdir}/aseba/switches/switch/asebaswitch" "${pkgdir}/usr/bin/asebaswitch"
+ install -Dm755 ${srcdir}/aseba/menu/freedesktop/48x48/* -t ${pkgdir}/usr/share/pixmaps/
+ install -Dm755 "${srcdir}/aseba/targets/challenge/examples/challenge-goto-energy.aesl" "${pkgdir}/usr/share/doc/aseba/example-code/challenge-goto-energy.aesl"
+ install -Dm755 "${srcdir}/aseba/targets/playground/examples/unifr.playground" "${pkgdir}/usr/share/doc/aseba/example-scenarios/unifr.playground"
+
}