summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTHS2020-07-15 12:32:22 +0200
committerTHS2020-07-15 13:01:47 +0200
commit3c5dd6015c0912f2b1237fe6f035965b626633fc (patch)
tree0725e7b81d76a6daaa4aa219d296dd5759ea5690
parent9f820ae314db9659d605e2c7d7092e653ef69565 (diff)
downloadaur-3c5dd6015c0912f2b1237fe6f035965b626633fc.tar.gz
Updated to Mobsya fork of aseba
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD74
2 files changed, 88 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ca8668c258e..da7d868e2099 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,60 @@
pkgbase = aseba-git
pkgdesc = A set of tools which allow beginners to program robots easily and efficiently.
- pkgver = 1.6.0
+ pkgver = 2.0.0.r35.gca18645f
pkgrel = 1
- url = https://github.com/aseba-community/aseba
+ url = https://github.com/Mobsya/aseba
install = aseba-git.install
arch = x86_64
license = LGPL3
+ makedepends = git
+ makedepends = ninja
+ makedepends = cmake
depends = boost
depends = doxygen
+ depends = qt5-charts
depends = qt5-tools
- depends = python2
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = qt5-graphicaleffects
+ depends = qt5-webengine
depends = sdl2
depends = qt5-svg
depends = avahi
+ depends = zzuf
+ depends = qwt
+ depends = python
provides = aseba
- source = dashel::git+https://github.com/aseba-community/dashel.git
- source = enki::git+https://github.com/enki-community/enki.git
- source = aseba::git+https://github.com/aseba-community/aseba.git
+ source = enki::git+https://github.com/Mobsya/enki
+ source = aseba::git+https://github.com/Mobsya/aseba.git
+ source = qtzeroconf::git+https://github.com/Mobsya/QtZeroConf
+ source = libusb::git+https://github.com/Mobsya/libusb.git
+ source = spdlog::git+https://github.com/gabime/spdlog
+ source = expected::git+https://github.com/TartanLlama/expected
+ source = aware::git+https://github.com/mobsya/aware
+ source = flatbuffers::git+https://github.com/google/flatbuffers
+ source = fmt::git+https://github.com/fmtlib/fmt.git
+ source = qt-solutions::git+https://github.com/qtproject/qt-solutions.git
+ source = park.variant::git+https://github.com/mpark/variant
+ source = pugixml::git+https://github.com/zeux/pugixml.git
+ source = range-v3::git+https://github.com/ericniebler/range-v3
+ source = quazip::git+https://github.com/mobsya/quazip
+ source = scratch-gui.tar.gz::https://github.com/Mobsya/scratch-gui/releases/download/v20200505.1/scratch-gui.tar.gz
+ source = thymio-blockly.tar.gz::https://github.com/Mobsya/thymio-blockly-standalone/releases/download/v20200506.1/thymio-blockly.tar.gz
+ source = vpl3-thymio-suite.tar.gz::https://github.com/Mobsya/ci-data/releases/download/data/vpl3-thymio-suite.tar.gz
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 584963c05d2a..625e724fa0ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,74 @@
# Maintainer: THS <mail@thson.de>
pkgname=aseba-git
-pkgver=1.6.0
+pkgver=2.0.0.r35.gca18645f
pkgrel=1
pkgdesc="A set of tools which allow beginners to program robots easily and efficiently."
arch=('x86_64')
-url="https://github.com/aseba-community/aseba"
+url="https://github.com/Mobsya/aseba"
license=('LGPL3')
provides=('aseba')
-depends=('boost' 'doxygen' 'qt5-tools' 'python2' 'sdl2' 'qt5-svg' 'avahi')
+makedepends=('git' 'ninja' 'cmake')
+depends=('boost' 'doxygen' 'qt5-charts' 'qt5-tools' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-graphicaleffects' 'qt5-webengine' 'sdl2' 'qt5-svg' 'avahi' 'zzuf' 'qwt' 'python')
install="aseba-git.install"
-source=('dashel::git+https://github.com/aseba-community/dashel.git'
- 'enki::git+https://github.com/enki-community/enki.git'
- 'aseba::git+https://github.com/aseba-community/aseba.git')
+source=('enki::git+https://github.com/Mobsya/enki'
+ 'aseba::git+https://github.com/Mobsya/aseba.git'
+ 'qtzeroconf::git+https://github.com/Mobsya/QtZeroConf'
+ 'libusb::git+https://github.com/Mobsya/libusb.git'
+ 'spdlog::git+https://github.com/gabime/spdlog'
+ 'expected::git+https://github.com/TartanLlama/expected'
+ 'aware::git+https://github.com/mobsya/aware'
+ 'flatbuffers::git+https://github.com/google/flatbuffers'
+ 'fmt::git+https://github.com/fmtlib/fmt.git'
+ 'qt-solutions::git+https://github.com/qtproject/qt-solutions.git'
+ 'park.variant::git+https://github.com/mpark/variant'
+ 'pugixml::git+https://github.com/zeux/pugixml.git'
+ 'range-v3::git+https://github.com/ericniebler/range-v3'
+ 'quazip::git+https://github.com/mobsya/quazip'
+ 'scratch-gui.tar.gz::https://github.com/Mobsya/scratch-gui/releases/download/v20200505.1/scratch-gui.tar.gz'
+ 'thymio-blockly.tar.gz::https://github.com/Mobsya/thymio-blockly-standalone/releases/download/v20200506.1/thymio-blockly.tar.gz'
+ 'vpl3-thymio-suite.tar.gz::https://github.com/Mobsya/ci-data/releases/download/data/vpl3-thymio-suite.tar.gz')
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "${srcdir}/aseba"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- msg2 "Adding submodules"
+ cp -rf $srcdir/scratch $srcdir/aseba/scratch
+ cp -rf $srcdir/thymio_blockly $srcdir/aseba/thymio_blockly
+ cp -rf $srcdir/vpl3-thymio-suite $srcdir/aseba/vpl3-thymio-suite
cd $srcdir/aseba
git submodule init
git config submodule.enki.url $srcdir/enki
- git config submodule.dashel.url $srcdir/dashel
+ git config submodule."third_party/QtZeroConf".url $srcdir/qtzeroconf
+ git config submodule."third_party/libusb/libusb".url $srcdir/libusb
+ git config submodule."third_party/spdlog/spdlog".url $srcdir/spdlog
+ git config submodule."third_party/expected/expected".url $srcdir/expected
+ git config submodule."third_party/aware".url $srcdir/aware
+ git config submodule."third_party/flatbuffers".url $srcdir/flatbuffers
+ git config submodule."third_party/fmt".url $srcdir/fmt
+ git config submodule."third_party/qt-solutions/qt-solutions".url $srcdir/qt-solutions
+ git config submodule."third_party/mpark.variant".url $srcdir/park.variant
+ git config submodule."third_party/pugixml".url $srcdir/pugixml
+ git config submodule."third_party/range-v3".url $srcdir/range-v3
+ git config submodule."third_party/quazip".url $srcdir/quazip
git submodule update
}
build() {
cd $srcdir/aseba
- mkdir build && cd build
- cmake -DBUILD_SHARED_LIBS=OFF -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python2.7 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
- make
+ mkdir -p build && cd build
+ cmake -GNinja -DMOBSYA_WEBAPPS_ROOT_DIR=share/ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=OFF ..
+ ninja
}
package() {
cd $srcdir/aseba/build
- make DESTDIR=$pkgdir install
-
- install -Dm755 "${srcdir}/aseba/menu/freedesktop/asebachallenge.desktop" "${pkgdir}/usr/share/applications/asebachallenge.desktop"
- install -Dm755 "${srcdir}/aseba/menu/freedesktop/asebaonlinehelp.desktop" "${pkgdir}/usr/share/applications/asebaonlinehelp.desktop"
- install -Dm755 "${srcdir}/aseba/menu/freedesktop/asebaplayground.desktop" "${pkgdir}/usr/share/applications/asebaplayground.desktop"
- install -Dm755 "${srcdir}/aseba/menu/freedesktop/asebastudio.desktop" "${pkgdir}/usr/share/applications/asebastudio.desktop"
- install -Dm755 "${srcdir}/aseba/menu/freedesktop/asebastudiothymio.desktop" "${pkgdir}/usr/share/applications/asebastudiothymio.desktop"
- install -Dm755 "${srcdir}/aseba/menu/freedesktop/thymioupgrader.desktop" "${pkgdir}/usr/share/applications/thymioupgrader.desktop"
- install -Dm755 "${srcdir}/aseba/menu/freedesktop/thymiovpl.desktop" "${pkgdir}/usr/share/applications/thymiovpl.desktop"
- install -Dm755 "${srcdir}/aseba/menu/freedesktop/thymiownetconfig.desktop" "${pkgdir}/usr/share/applications/thymiownetconfig.desktop"
- install -Dm755 ${srcdir}/aseba/menu/freedesktop/48x48/* -t ${pkgdir}/usr/share/pixmaps/
- install -Dm755 ${srcdir}/aseba/aseba/targets/challenge/examples/*.aesl -t ${pkgdir}/usr/share/doc/aseba/example-code/
- install -Dm755 "${srcdir}/aseba/aseba/targets/playground/examples/thymio-default-behaviours.aesl" "${pkgdir}/usr/share/doc/aseba/example-scenarios/thymio-default-behaviours.aesl"
- install -Dm755 ${srcdir}/aseba/aseba/targets/playground/examples/*.png -t ${pkgdir}/usr/share/doc/aseba/example-scenarios/
- install -Dm755 ${srcdir}/aseba/aseba/targets/playground/examples/*.playground -t ${pkgdir}/usr/share/doc/aseba/example-scenarios/
- install -Dm755 ${srcdir}/aseba/aseba/targets/playground/examples/*.aesl -t ${pkgdir}/usr/share/doc/aseba/example-code/
+ DESTDIR=$pkgdir ninja install
+
+ install -D --target-directory $pkgdir/usr/share/mobsya/Playground/ $srcdir/aseba/aseba/targets/playground/examples/*
}