summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTHS2016-12-18 23:39:43 +0100
committerTHS2016-12-18 23:39:43 +0100
commit50a12708750068fe8b25b82816dea6ca9b25b5ae (patch)
treee8fa57115e653c2ae27bf688e0060f4855ab993b
parent18cf281c527c424063bbe938650575581abd9311 (diff)
downloadaur-50a12708750068fe8b25b82816dea6ca9b25b5ae.tar.gz
removed dependency on Catch and fixed enki build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7911571fbe90..781837de8ab7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aseba-git
pkgdesc = A set of tools which allow beginners to program robots easily and efficiently.
- pkgver = 1.5.3.r102.g8ccdc9d
+ pkgver = 1.5.3.r125.ga376fa6b
pkgrel = 1
url = https://github.com/aseba-community/aseba
install = aseba-git.install
@@ -21,13 +21,11 @@ pkgbase = aseba-git
source = dashel::git+https://github.com/aseba-community/dashel.git
source = enki::git+https://github.com/enki-community/enki.git
source = aseba::git+https://github.com/aseba-community/aseba.git
- source = catch::git+https://github.com/philsquared/Catch
source = blockly::git+https://github.com/aseba-community/blockly.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = aseba-git
diff --git a/PKGBUILD b/PKGBUILD
index 587540d2a39a..35a87878c3b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: THS <mail@thson.de>
pkgname=aseba-git
-pkgver=1.5.3.r102.g8ccdc9d
+pkgver=1.5.3.r125.ga376fa6b
pkgrel=1
pkgdesc="A set of tools which allow beginners to program robots easily and efficiently."
arch=('x86_64')
@@ -12,10 +12,9 @@ install="aseba-git.install"
source=('dashel::git+https://github.com/aseba-community/dashel.git'
'enki::git+https://github.com/enki-community/enki.git'
'aseba::git+https://github.com/aseba-community/aseba.git'
- 'catch::git+https://github.com/philsquared/Catch'
'blockly::git+https://github.com/aseba-community/blockly.git')
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "${srcdir}/aseba"
@@ -25,8 +24,8 @@ pkgver() {
prepare() {
msg2 "Adding submodules"
cd $srcdir/aseba
+ git rm tests/externals/Catch/ #Fix to start init
git submodule init
- git config submodule.catch.url $srcdir/catch
git config submodule.blockly.url $srcdir/blockly
git submodule update
}
@@ -39,6 +38,7 @@ cmake ../dashel -DCMAKE_BUILD_TYPE=RelWithDebInfo -DBUILD_SHARED_LIBS=OFF
make
cd ..
cd build-enki
+export enki_DIR=${srcdir}/build-enki
cmake ../enki -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python2 #Only Python2 works
make
cd ..