summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartina Pietruschka2015-12-22 15:49:18 +0000
committerMartina Pietruschka2015-12-22 15:49:18 +0000
commit9baa2516a29c64df41333e03df89cc5b29d7b07a (patch)
tree13d41fba03647f4a138f29824b2f272abe7a17ba
downloadaur-9baa2516a29c64df41333e03df89cc5b29d7b07a.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
-rw-r--r--plist.patch11
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c9e19025a69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Dec 22 15:47:12 UTC 2015
+pkgbase = asekey
+ pkgdesc = ASEKey USB and SIM Reader driver for PCSC Lite
+ pkgver = 3.7
+ pkgrel = 2
+ url = http://www.athena-scs.com/support/software-driver-downloads
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = pcsclite
+ source = http://www.athena-scs.com/docs/reader-drivers/asekey-3-7-tar.bz2
+ source = plist.patch
+ md5sums = 2a66073c202e10becd8a0cdc55a720a9
+ md5sums = 54a6bdf6a9e4a0b980a278227f32f93e
+
+pkgname = asekey
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..346eb0d10812
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: MartiMcFly <martimcfly at autorisation de
+
+pkgname=asekey
+pkgver=3.7
+pkgrel=2
+pkgdesc="ASEKey USB and SIM Reader driver for PCSC Lite"
+arch=('armv6h' 'armv7h' 'i686' 'x86_64')
+license="LGPL"
+depends=('pcsclite')
+url="http://www.athena-scs.com/support/software-driver-downloads"
+source=("http://www.athena-scs.com/docs/reader-drivers/asekey-3-7-tar.bz2"
+ "plist.patch")
+md5sums=('2a66073c202e10becd8a0cdc55a720a9'
+ '54a6bdf6a9e4a0b980a278227f32f93e')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ patch -p1 < "${srcdir}"/plist.patch
+ ./configure --prefix=/usr --with-udev-rules-dir=/usr/lib/udev/rules.d
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/plist.patch b/plist.patch
new file mode 100644
index 000000000000..bee606332c2b
--- /dev/null
+++ b/plist.patch
@@ -0,0 +1,11 @@
+diff -Naur ../o/Info.plist ./Info.plist
+--- ../o/Info.plist 2012-12-16 19:46:48.000000000 +0000
++++ ./Info.plist 2015-12-22 02:55:13.030162838 +0000
+@@ -14,6 +14,7 @@
+ <string>ASEKey</string>
+ <string>ASEKey</string>
+ </array>
++ <key>CFBundleExecutable</key>
+ <array>
+ <string>libASEKey.so</string>
+ <string>libASEKey.so</string>