summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilson E. Alvarez2018-03-16 19:56:21 -0400
committerWilson E. Alvarez2018-03-16 19:56:30 -0400
commit03fef6d621a1841f468e1154564dcdbbc40537ae (patch)
treeb6d87d4380db3f40de535914b9d9cf82ef60907c
parente964b5167614a40803d6e30dfcfe5714714bb519 (diff)
downloadaur-03fef6d621a1841f468e1154564dcdbbc40537ae.tar.gz
aseprite v1.2.7
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b8adce13502..6185631ac372 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Dec 20 11:52:17 UTC 2017
+# Fri Mar 16 23:56:01 UTC 2018
pkgbase = aseprite
pkgdesc = Create animated sprites and pixel art
- pkgver = 1.2.6
+ pkgver = 1.2.7
pkgrel = 1
url = http://www.aseprite.org/
arch = x86_64
arch = i686
license = custom
makedepends = cmake
+ depends = cmark
depends = pixman
depends = curl
depends = giflib
@@ -18,11 +19,13 @@ pkgbase = aseprite
depends = tinyxml
depends = freetype2
depends = libwebp
+ depends = harfbuzz
+ depends = allegro4
conflicts = aseprite-git
conflicts = aseprite-gpl
- source = https://github.com/aseprite/aseprite/releases/download/v1.2.6/Aseprite-v1.2.6-Source.zip
+ source = https://github.com/aseprite/aseprite/releases/download/v1.2.7/Aseprite-v1.2.7-Source.zip
source = aseprite.desktop
- sha256sums = e92a9c19cb5d36c64f8ee916ca34f8c2d628beadc58ab75c4718bd99683f8972
+ sha256sums = 31ad9ea7bf48fb35cfa05c2860856ca61a74731222e41871241b1576f6ede40d
sha256sums = c258fa38a0e0bd575f0bd744c4c3b60cf8d59d596c7572f84bd392e1c5e49b4f
pkgname = aseprite
diff --git a/PKGBUILD b/PKGBUILD
index d3a5eafb45b0..da72093d212e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,19 @@
# Contributor: Kamil BiduĊ› <kamil.bidus@gmail.com>
pkgname=aseprite
-pkgver=1.2.6
+pkgver=1.2.7
pkgrel=1
pkgdesc='Create animated sprites and pixel art'
arch=('x86_64' 'i686')
url="http://www.aseprite.org/"
license=('custom')
-depends=('pixman' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype2' 'libwebp')
+depends=('cmark' 'pixman' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype2' 'libwebp' 'harfbuzz' 'allegro4')
makedepends=('cmake')
conflicts=("aseprite-git" "aseprite-gpl")
source=("https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/Aseprite-v${pkgver}-Source.zip"
"${pkgname}.desktop")
-sha256sums=('e92a9c19cb5d36c64f8ee916ca34f8c2d628beadc58ab75c4718bd99683f8972'
+sha256sums=('31ad9ea7bf48fb35cfa05c2860856ca61a74731222e41871241b1576f6ede40d'
'c258fa38a0e0bd575f0bd744c4c3b60cf8d59d596c7572f84bd392e1c5e49b4f')
-
build() {
cd "$srcdir"
@@ -35,18 +34,17 @@ build() {
-DUSE_SHARED_CURL=ON \
-DUSE_SHARED_GIFLIB=ON \
-DUSE_SHARED_JPEGLIB=ON \
+ -DUSE_SHARED_HARFBUZZ=ON \
-DUSE_SHARED_ZLIB=ON \
-DUSE_SHARED_LIBPNG=ON \
- -DUSE_SHARED_LIBLOADPNG=OFF \
+ -DUSE_SHARED_LIBLOADPNG=ON \
-DUSE_SHARED_TINYXML=ON \
+ -DUSE_SHARED_CMARK=ON \
-DENABLE_UPDATER=OFF \
- -DUSE_SHARED_FREETYPE=OFF \
+ -DUSE_SHARED_FREETYPE=ON \
+ -DUSE_SHARED_ALLEGRO4=ON \
-DCMAKE_INSTALL_PREFIX:STRING=/usr ..
- # TODO: Note that using the shared freetype library was disabled for aseprite v1.24 due to a missing header
- # Double check if we can use the shared library later on to minimize package size
- #-DFREETYPE_INCLUDE_DIR=/usr/include/freetype2 \
-
make $MAKEFLAGS
}
@@ -59,12 +57,12 @@ package() {
install -Dm644 "../data/icons/ase48.png" \
"$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "../EULA.txt" "$pkgdir/usr/share/licenses/$pkgname/EULA.txt"
- # WARNING: fix for upstream including gtest and cmark in "make install"
- rm -rf "$pkgdir/usr/include" "$pkgdir/usr/lib" "$pkgdir/usr/share/man" "$pkgdir/usr/bin/cmark"
# Remove conflicting files with libarchive
# TODO: With the current compilation options, looks like aseprite build process builds these binaries. Disable the compilation of the following files later on:
+ # Note: Github issue: https://github.com/aseprite/aseprite/issues/1602
rm -f "$pkgdir/usr/bin/"{bsdcat,bsdcpio,bsdtar}
+ rm -rf "$pkgdir/usr/include" "$pkgdir/usr/lib" "$pkgdir/usr/share/man" "$pkgdir/usr/bin/cmark"
}
# vim:set ts=2 sw=2 et: