summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Favre2015-11-09 10:01:03 +0100
committerBenoit Favre2015-11-09 10:01:03 +0100
commit3bcf189c37a81b30486655a1484551e4186e8fa3 (patch)
tree9a0c526199fe1f144ac06fb4389d4b1932971867
parent08c49454815675b48aad417bb489813e6051701b (diff)
downloadaur-3bcf189c37a81b30486655a1484551e4186e8fa3.tar.gz
fix overwritten freetype files
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 372747fd539f..7f999c1fad77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aseprite
pkgdesc = Create animated sprites and pixel art
pkgver = 1.1.1
- pkgrel = 2
+ pkgrel = 3
url = http://www.aseprite.org/
arch = x86_64
arch = i686
@@ -14,7 +14,7 @@ pkgbase = aseprite
depends = libpng
depends = libjpeg-turbo
depends = tinyxml
- depends = freetype
+ depends = freetype2
source = git+https://github.com/aseprite/aseprite.git#tag=v1.1.1
source = aseprite.desktop
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c1cef46cce47..daa29c82831f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=aseprite
pkgver=1.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='Create animated sprites and pixel art'
arch=('x86_64' 'i686')
url='http://www.aseprite.org/'
license=('GPL')
-depends=('pixman' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype')
+depends=('pixman' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype2')
makedepends=('cmake')
source=("git+https://github.com/aseprite/aseprite.git#tag=v${pkgver}"
"aseprite.desktop")
@@ -29,6 +29,8 @@ build() {
-DUSE_SHARED_LIBLOADPNG=OFF \
-DUSE_SHARED_TINYXML=ON \
-DENABLE_UPDATER=OFF \
+ -DUSE_SHARED_FREETYPE=ON \
+ -DFREETYPE_INCLUDE_DIR=/usr/include/freetype2 \
-DCMAKE_INSTALL_PREFIX:STRING=/usr ..
make aseprite
}