summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorISSOtm2022-01-13 19:50:36 +0100
committerISSOtm2022-01-13 20:00:54 +0100
commit5571395d6809ff0b37d949a7d40d7969ccbfbd24 (patch)
tree50e231bf901f02b9be5a682b0aea45775db910ab
parente1fbe636bc2a4a3391b66ecaf3a8ce075ceff142 (diff)
downloadaur-5571395d6809ff0b37d949a7d40d7969ccbfbd24.tar.gz
Fix up desktop integration
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD4
-rw-r--r--desktop.patch25
4 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c49e9047fd36..0177f8520004 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -36,6 +36,7 @@ pkgbase = aseprite
source = git+https://github.com/aseprite/skia.git#branch=aseprite-m96
source = git+https://chromium.googlesource.com/chromium/buildtools.git#commit=505de88083136eefd056e5ee4ca0f01fe9b33de8
source = git+https://skia.googlesource.com/common.git#commit=9737551d7a52c3db3262db5856e6bcd62c462b92
+ source = desktop.patch
source = shared-libarchive.patch
source = shared-libwebp.patch
source = shared-skia-deps.patch
@@ -44,6 +45,7 @@ pkgbase = aseprite
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 8b14e36939e930de581e95abf0591645aa0fcfd47161cf88b062917dbaaef7f9
sha256sums = e42675504bfbc17655aef1dca957041095026cd3dd4e6981fb6df0a363948aa7
sha256sums = 2d6b5f33f23adc4f9912511ac35311a776ce34519ef40e9db3659e4c5457f055
sha256sums = eb9f544e68b41b5cb1a9ab7a6648db51587e67e94f1a452cb5a84f3d224bf5d0
diff --git a/.gitignore b/.gitignore
index 565da6464bc7..d0ea81c8f52b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,7 @@
!/.gitignore
!/.SRCINFO
!/PKGBUILD
+!/desktop.patch
!/shared-libarchive.patch
!/shared-libwebp.patch
!/shared-skia-deps.patch
diff --git a/PKGBUILD b/PKGBUILD
index 16208e41cad5..15c17777ff69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,6 +40,7 @@ source=("https://github.com/aseprite/aseprite/releases/download/v$pkgver/Aseprit
# Only pulling what we need, though
"git+https://chromium.googlesource.com/chromium/buildtools.git#commit=505de88083136eefd056e5ee4ca0f01fe9b33de8"
"git+https://skia.googlesource.com/common.git#commit=9737551d7a52c3db3262db5856e6bcd62c462b92"
+ desktop.patch
# Based on https://patch-diff.githubusercontent.com/raw/aseprite/aseprite/pull/2535.patch
shared-libarchive.patch
# Based on https://patch-diff.githubusercontent.com/raw/aseprite/aseprite/pull/2523.patch
@@ -51,6 +52,7 @@ sha256sums=('966bd940e1072ed24b70e211ca2bb1eb9aa6432ca12972a8e1df5f1e0150213d'
'SKIP'
'SKIP'
'SKIP'
+ '8b14e36939e930de581e95abf0591645aa0fcfd47161cf88b062917dbaaef7f9'
'e42675504bfbc17655aef1dca957041095026cd3dd4e6981fb6df0a363948aa7'
'2d6b5f33f23adc4f9912511ac35311a776ce34519ef40e9db3659e4c5457f055'
'eb9f544e68b41b5cb1a9ab7a6648db51587e67e94f1a452cb5a84f3d224bf5d0'
@@ -71,6 +73,8 @@ prepare() {
ln -svfT "$(realpath $_dep)" "skia/${_skiadeps[$_dep]}"
done
+ # Fix up Aseprite's desktop integration
+ env -C aseprite patch -tp1 <desktop.patch
# Allow using shared libarchive (the bundled version prevents using the `None` build type...)
env -C aseprite patch -tp1 <shared-libarchive.patch
# Allow using shared libwebp (breaks builds otherwise...)
diff --git a/desktop.patch b/desktop.patch
new file mode 100644
index 000000000000..fcb047550f7b
--- /dev/null
+++ b/desktop.patch
@@ -0,0 +1,25 @@
+diff --git a/src/desktop/linux/aseprite.desktop b/src/desktop/linux/aseprite.desktop
+index e23999db8..803a1fc75 100644
+--- a/src/desktop/linux/aseprite.desktop
++++ b/src/desktop/linux/aseprite.desktop
+@@ -5,7 +5,7 @@ GenericName=Sprite Editor
+ Comment=Animated sprite editor & pixel art tool
+ Icon=aseprite
+ Categories=Graphics;2DGraphics;RasterGraphics
+-Exec=aseprite %U
++Exec=aseprite %F
+ TryExec=aseprite
+ Terminal=false
+ StartupNotify=false
+diff --git a/src/desktop/linux/mime/aseprite.xml b/src/desktop/linux/mime/aseprite.xml
+index 52b2adb92..a656cb3b1 100644
+--- a/src/desktop/linux/mime/aseprite.xml
++++ b/src/desktop/linux/mime/aseprite.xml
+@@ -7,6 +7,6 @@
+ </magic>
+ <glob pattern="*.ase"/>
+ <glob pattern="*.aseprite"/>
+- <icon name="aseprite"/>
++ <icon name="image-x-aseprite"/>
+ </mime-type>
+ </mime-info>