summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorISSOtm2022-01-13 19:45:45 +0100
committerISSOtm2022-01-13 19:53:21 +0100
commite1fbe636bc2a4a3391b66ecaf3a8ce075ceff142 (patch)
tree49b8cf29df460e6cab896e928d6fd840a0fd2bd9
parent20382399c1d1ea6de2d9b4222c291b6643671176 (diff)
downloadaur-e1fbe636bc2a4a3391b66ecaf3a8ce075ceff142.tar.gz
Use upstream `is_clang.py`
The new version works fine under Python 3
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD6
-rwxr-xr-xis_clang.py17
4 files changed, 0 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88add275bab8..c49e9047fd36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -36,7 +36,6 @@ pkgbase = aseprite
source = git+https://github.com/aseprite/skia.git#branch=aseprite-m96
source = git+https://chromium.googlesource.com/chromium/buildtools.git#commit=505de88083136eefd056e5ee4ca0f01fe9b33de8
source = git+https://skia.googlesource.com/common.git#commit=9737551d7a52c3db3262db5856e6bcd62c462b92
- source = is_clang.py
source = shared-libarchive.patch
source = shared-libwebp.patch
source = shared-skia-deps.patch
@@ -45,7 +44,6 @@ pkgbase = aseprite
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = cb901aaf479bcf1a2406ce21eb31e43d3581712a9ea245672ffd8fbcd9190441
sha256sums = e42675504bfbc17655aef1dca957041095026cd3dd4e6981fb6df0a363948aa7
sha256sums = 2d6b5f33f23adc4f9912511ac35311a776ce34519ef40e9db3659e4c5457f055
sha256sums = eb9f544e68b41b5cb1a9ab7a6648db51587e67e94f1a452cb5a84f3d224bf5d0
diff --git a/.gitignore b/.gitignore
index bb36aa2be261..565da6464bc7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,7 +2,6 @@
!/.gitignore
!/.SRCINFO
!/PKGBUILD
-!/is_clang.py
!/shared-libarchive.patch
!/shared-libwebp.patch
!/shared-skia-deps.patch
diff --git a/PKGBUILD b/PKGBUILD
index edc712081c43..16208e41cad5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,8 +40,6 @@ source=("https://github.com/aseprite/aseprite/releases/download/v$pkgver/Aseprit
# Only pulling what we need, though
"git+https://chromium.googlesource.com/chromium/buildtools.git#commit=505de88083136eefd056e5ee4ca0f01fe9b33de8"
"git+https://skia.googlesource.com/common.git#commit=9737551d7a52c3db3262db5856e6bcd62c462b92"
- # Python 3-compliant version of the script
- is_clang.py
# Based on https://patch-diff.githubusercontent.com/raw/aseprite/aseprite/pull/2535.patch
shared-libarchive.patch
# Based on https://patch-diff.githubusercontent.com/raw/aseprite/aseprite/pull/2523.patch
@@ -53,7 +51,6 @@ sha256sums=('966bd940e1072ed24b70e211ca2bb1eb9aa6432ca12972a8e1df5f1e0150213d'
'SKIP'
'SKIP'
'SKIP'
- 'cb901aaf479bcf1a2406ce21eb31e43d3581712a9ea245672ffd8fbcd9190441'
'e42675504bfbc17655aef1dca957041095026cd3dd4e6981fb6df0a363948aa7'
'2d6b5f33f23adc4f9912511ac35311a776ce34519ef40e9db3659e4c5457f055'
'eb9f544e68b41b5cb1a9ab7a6648db51587e67e94f1a452cb5a84f3d224bf5d0'
@@ -74,9 +71,6 @@ prepare() {
ln -svfT "$(realpath $_dep)" "skia/${_skiadeps[$_dep]}"
done
- # Replace `is_clang.py` with Python 3-compliant version
- cp -v is_clang.py skia/gn
-
# Allow using shared libarchive (the bundled version prevents using the `None` build type...)
env -C aseprite patch -tp1 <shared-libarchive.patch
# Allow using shared libwebp (breaks builds otherwise...)
diff --git a/is_clang.py b/is_clang.py
deleted file mode 100755
index 5209d533ceac..000000000000
--- a/is_clang.py
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/usr/bin/env python3
-#
-# Copyright 2016 Google Inc.
-#
-# Use of this source code is governed by a BSD-style license that can be
-# found in the LICENSE file.
-
-import subprocess
-import sys
-cc,cxx = sys.argv[1:3]
-
-if (b'clang' in subprocess.check_output('%s --version' % cc, shell=True) and
- b'clang' in subprocess.check_output('%s --version' % cxx, shell=True)):
- print('true')
-else:
- print('false')
-