summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLarzid2020-08-26 02:57:24 -0500
committerLarzid2020-08-26 02:57:24 -0500
commitec439a20034ff91139537814ea7ee90f3857c12e (patch)
tree09b17349d96e20d472d9498f25e7e53cac75cda2
downloadaur-ec439a20034ff91139537814ea7ee90f3857c12e.tar.gz
package created
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d8600bb52a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = asetroot
+ pkgdesc = A lightweight animated wallpaper program for openbox & other light WMs
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/Wilnath/asetroot
+ arch = x86_64
+ license = MIT
+ makedepends = make
+ makedepends = git
+ depends = imlib2
+ depends = libx11
+ provides = asetroot
+ source = git+https://github.com/Wilnath/asetroot.git
+ md5sums = SKIP
+
+pkgname = asetroot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9323431a2bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Maintainer: Larzid <larzid.dev@gmail.com>
+pkgname=asetroot
+pkgver=0.1
+pkgrel=1
+epoch=
+pkgdesc="A lightweight animated wallpaper program for openbox & other light WMs"
+arch=('x86_64')
+url="https://github.com/Wilnath/asetroot"
+license=('MIT')
+groups=()
+depends=('imlib2' 'libx11')
+makedepends=('make' 'git')
+checkdepends=()
+provides=(asetroot)
+replaces=()
+backup=()
+options=()
+changelog=
+source=('git+https://github.com/Wilnath/asetroot.git')
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd asetroot
+ make
+ }
+
+package() {
+ install -D ${srcdir}/asetroot/asetroot ${pkgdir}/usr/bin/asetroot
+ }