summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2020-06-25 11:11:21 +0200
committerGilrain2020-06-25 11:11:21 +0200
commit2a8b9cf725d557f9c2fd68b940ee6751faba2751 (patch)
tree34cb8a23d7a08d9ac42eecedba8db256a972cdba
parente21dc2291edeb7ad07e22a53943f33ab14f06f3b (diff)
downloadaur-2a8b9cf725d557f9c2fd68b940ee6751faba2751.tar.gz
Update to 4.2.3.3-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--changelog14
3 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b24408be2340..c860ceead16b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asf
pkgdesc = Steam cards farmer.
- pkgver = 4.2.2.1
+ pkgver = 4.2.3.3
pkgrel = 1
url = https://github.com/JustArchiNET/ArchiSteamFarm
install = install
@@ -15,7 +15,7 @@ pkgbase = asf
optdepends = asf-ui: standalone web interface for ASF
backup = var/lib/asf/config/ASF.json
backup = usr/lib/asf/NLog.config
- source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=4.2.2.1
+ source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=4.2.3.3
source = service
source = service.user
source = ASF.json
diff --git a/PKGBUILD b/PKGBUILD
index 517fb6c0de5a..b8037ba57660 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Lucki
pkgname="asf"
-pkgver="4.2.2.1"
+pkgver="4.2.3.3"
pkgrel=1
pkgdesc="Steam cards farmer."
arch=('x86_64' 'armv7h' 'aarch64')
@@ -32,10 +32,10 @@ build() {
}
package() {
- cd asf/out
+ cd asf/out/result
install -d -m 755 "${pkgdir}/usr/lib/${pkgname}"
cp -rdp --no-preserve=ownership . "${pkgdir}/usr/lib/asf"
- install -D -m755 ../run.sh "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m755 ../../run.sh "${pkgdir}/usr/bin/${pkgname}"
sed -i 's,^\(BINARY_PATH[ ]*=\).*,\1'/usr/lib/asf',g' "${pkgdir}/usr/bin/${pkgname}"
find "${pkgdir}/usr/lib/${pkgname}" -type f -exec chmod 644 {} \;
find "${pkgdir}/usr/lib/${pkgname}" -type d -exec chmod 755 {} \;
diff --git a/changelog b/changelog
index 0208fec3f511..9d628340f070 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,17 @@
+2020-06-25 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 4.2.3.3-1:
+ Added Steam Summer Sale 2020 to SalesBlacklist (#1853).
+ ASF now comes bundled with its first official plugin, SteamTokenDumperPlugin. Check out our wiki for exact details on the plugin, including how to activate it. People using docker might need to rebuild their containers with docker volume rm on old ASF volumes.
+ We've slightly changed our MatchActively algorithm to increase chance of finding rare matches, you can read more about that on our wiki.
+ Fixed an issue of ASF running into a possible deadlock with cross-process limiters on Windows machines.
+ Fixed ASF being unable to fetch app info for non-public apps (e.g. publisher banned).
+ Latest ASF-ui with new features, improvements and bugfixes.
+ Updated localization provided by our community.
+ Usual amount of other core improvements, optimizations and bugfixes.
+ Includes bugfix for #1862.\
+ pkg: package dir changed to conform with build script output
+ pkg: replace custom launch script with upstream's
+ pkg: prevent build script from pulling git repos
2020-06-23 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 4.2.2.1-1:
Fixed ASF being unable to fetch info about newer non-public packages requiring access token (#1827). This was required due to recent Steam change, making it impossible for ASF to work like previously.