summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2020-09-21 17:35:21 +0200
committerGilrain2020-09-21 17:35:21 +0200
commit3d4c3443900ea3de4256ca03192f11b505e48dde (patch)
treea6a9e381aaadf6726b3412f7870f02ed80c6647b
parent76bcf0de540f7998fa8f56a912fc71680de2a797 (diff)
downloadaur-3d4c3443900ea3de4256ca03192f11b505e48dde.tar.gz
Update to 4.3.0.6-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--changelog14
3 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57fb76070d72..ab4eb9c0a1bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asf
pkgdesc = Steam cards farmer.
- pkgver = 4.2.4.0
+ pkgver = 4.3.0.6
pkgrel = 1
url = https://github.com/JustArchiNET/ArchiSteamFarm
install = install
@@ -15,7 +15,7 @@ pkgbase = asf
optdepends = asf-ui: standalone web interface for ASF
backup = var/lib/asf/config/ASF.json
backup = usr/lib/asf/NLog.config
- source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=4.2.4.0
+ source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=4.3.0.6
source = service
source = service.user
source = ASF.json
diff --git a/PKGBUILD b/PKGBUILD
index ee883c01a7e8..7c1fa20e194e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Lucki
pkgname="asf"
-pkgver="4.2.4.0"
+pkgver="4.3.0.6"
pkgrel=1
pkgdesc="Steam cards farmer."
arch=('x86_64' 'armv7h' 'aarch64')
diff --git a/changelog b/changelog
index 3a60da487949..2248132b43ae 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,17 @@
+2020-09-21 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 4.3.0.6-1:
+ [!] General code refactor for implementing C# 8.0 nullable references. This change might require some third-party plugins to be recompiled, due to misc API changes that had to be applied in the process (#1543).
+ [!] ASF now supports specifying custom headers and cookies with a WebBrowser request - this is a breaking API change which might require some third-party plugins to be recompiled with additional code fixes (#1964).
+ [!] ASF will no longer retry requests upon receiving 5xx strError response during accepting a trade offer. This change slightly modifies internal API of (...)WithSession() functions, which may require plugin recompilation of third-party plugins (#1832).
+ AdditionalProperties field of Steam.Asset has been changed to AdditionalPropertiesReadOnly to allow proper extension deserialization. If you're a plugin developer and using this field, please adapt your usage (#1958).
+ ASF will now use a GET request for 301 and 302 redirections (#1963).
+ Added encrypt command (#1950).
+ Fixed ASF not accepting case-insensitive 2FA codes (regression).
+ Fixed a possibility of level command to produce response for unauthorized users (#1957).
+ Latest ASF-ui with new features, improvements and bugfixes.
+ Updated localization provided by our community.
+ Usual amount of other core improvements, optimizations and bugfixes.
+ [Deprecation] Endpoints deprecated in the previous release have been removed.
2020-08-19 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 4.2.4.0-1:
Added POST /Api/Bot/{botNames}/TwoFactorAuthentication/Confirmations API endpoint which allows to accept/reject confirmations with more parameters.