summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2021-10-02 15:53:14 +0200
committerGilrain2021-10-02 15:53:14 +0200
commit48d43ffcb22c60be21ab4039ed2ac11686b3251b (patch)
tree17a11e3cb15eccdfd969a87e266f47c11103a8dc
parent0fcf03f4f13067b14c0e66ae15f9075aebc6b17a (diff)
downloadaur-48d43ffcb22c60be21ab4039ed2ac11686b3251b.tar.gz
Update to 5.1.4.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--asf.env1
-rw-r--r--changelog15
-rw-r--r--install13
-rw-r--r--service18
-rw-r--r--service.patch20
-rw-r--r--service.user13
8 files changed, 65 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06c2d3769862..c1516a4d1cc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asf
pkgdesc = Steam cards farmer.
- pkgver = 5.1.3.6
+ pkgver = 5.1.4.0
pkgrel = 1
url = https://github.com/JustArchiNET/ArchiSteamFarm
install = install
@@ -15,14 +15,14 @@ pkgbase = asf
optdepends = asf-ui: standalone web interface for ASF
backup = var/lib/asf/config/ASF.json
backup = usr/lib/asf/NLog.config
- source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=5.1.3.6
- source = service
- source = service.user
+ source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=5.1.4.0
+ source = service.patch
+ source = asf.env
source = ASF.json
source = NLog.config
sha256sums = SKIP
- sha256sums = ba1ff85e55e56d71dbdd0d898244ff7725bced8625f29c5389e28525e6cdb987
- sha256sums = b627c8d4b3ba7f194a44749bd401b33bae601b9570da98e457737a6f9cfa408f
+ sha256sums = 18b8b32774df8b9cfc4e75f003a29119b2fbccf6c582afa7c404485222c5b818
+ sha256sums = ec82f54a9b362e2305a775eb1473522636ab724f18d846828410c39344801db4
sha256sums = c300c5ce63c0237d7558b5b303159b8e2a8e5323f581cc8435dd2a6f1ead5332
sha256sums = c6d8dff9306532babf5100629ea48a5322561823a4c7416f02dacbbee5ab30da
diff --git a/PKGBUILD b/PKGBUILD
index 3d97c8d63033..c37cef787a3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Lucki
pkgname="asf"
-pkgver="5.1.3.6"
+pkgver="5.1.4.0"
pkgrel=1
pkgdesc="Steam cards farmer."
arch=('x86_64' 'armv7h' 'aarch64')
@@ -15,16 +15,21 @@ changelog=changelog
backup=('var/lib/asf/config/ASF.json' 'usr/lib/asf/NLog.config')
install=install
source=("asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=${pkgver}"
- "service"
- "service.user"
+ "service.patch"
+ "asf.env"
"ASF.json"
"NLog.config")
sha256sums=('SKIP'
- 'ba1ff85e55e56d71dbdd0d898244ff7725bced8625f29c5389e28525e6cdb987'
- 'b627c8d4b3ba7f194a44749bd401b33bae601b9570da98e457737a6f9cfa408f'
+ '18b8b32774df8b9cfc4e75f003a29119b2fbccf6c582afa7c404485222c5b818'
+ 'ec82f54a9b362e2305a775eb1473522636ab724f18d846828410c39344801db4'
'c300c5ce63c0237d7558b5b303159b8e2a8e5323f581cc8435dd2a6f1ead5332'
'c6d8dff9306532babf5100629ea48a5322561823a4c7416f02dacbbee5ab30da')
+prepare() {
+ cd ${srcdir}/asf/ArchiSteamFarm/overlay/linux
+ patch --forward --input="${srcdir}/service.patch"
+}
+
build() {
cd asf
export DOTNET_CLI_TELEMETRY_OPTOUT=1
@@ -44,8 +49,8 @@ package() {
install -D -m644 "${srcdir}/ASF.json" "${pkgdir}/var/lib/${pkgname}/config/ASF.json"
install -D -m644 "${srcdir}/NLog.config" "${pkgdir}/usr/lib/${pkgname}/NLog.config"
- install -D -m644 "${srcdir}/service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
- install -D -m644 "${srcdir}/service.user" "${pkgdir}/usr/lib/systemd/user/${pkgname}.service"
+ install -D -m644 "${srcdir}/asf.env" "${pkgdir}/etc/asf/asf"
+ install -D -m644 "${srcdir}/asf/ArchiSteamFarm/overlay/linux/ArchiSteamFarm@.service" "${pkgdir}/usr/lib/systemd/system/ArchiSteamFarm@.service"
# Setup system user and group
echo 'u asf - "ArchiSteamFarm" /var/lib/asf' |
diff --git a/asf.env b/asf.env
new file mode 100644
index 000000000000..90a9f107981c
--- /dev/null
+++ b/asf.env
@@ -0,0 +1 @@
+ASF_PATH=/var/lib/asf
diff --git a/changelog b/changelog
index 39d0546eeba0..43e9c33b3207 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,18 @@
+2021-10-02 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 5.1.4.0-1:
+ Added ArchiSteamFarm@.service service file declarations for systemd to generic, generic-netf and linux variants. Since their exact usage is not documented on the wiki yet, they're in the preview state for the brave sunglasses.
+ Added --service command-line argument which forces Headless: true, used mainly for service files mentioned above.
+ Fixed ASF wrongly responding with "unknown command" when it should respond with "access denied" instead.
+ Latest ASF-ui with new features, improvements and bugfixes.
+ Updated localization provided by our community.
+ Usual amount of other core improvements, optimizations and bugfixes.
+ pkg: adopted upstream service file
+ * 5.1.3.9:
+ Fixed regression affecting generic-netf builds introduced in version 5.1.2.0 that broke automatic update capability. Existing generic-netf users are advised to update their ASFs manually to this (or newer) release in order to fix the problem. This bug does not affect any other setups, it's exclusive to generic-netf variant.
+ * 5.1.3.8:
+ Failed attempt at fixing generic-netf update capability
+ * 5.1.3.7:
+ Fixed regression that caused excessive delay during program shutdown on Windows machines.
2021-09-02 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 5.1.3.6-1:
We've reverted our change introduced as part of V5.1.3.2 in which the builds are built on the corresponding OSes due to issue dotnet/msbuild#3897 which caused missing Chinese translation (among some other) on non-Windows builds of ASF. Fortunately, this doesn't affect the chmod +x improvement which stays with us as part of this feature release (ref: #2411).
diff --git a/install b/install
index 09704734243f..5a73cfcf4fa4 100644
--- a/install
+++ b/install
@@ -1,3 +1,12 @@
post_install() {
- echo "# configuration is done in /var/lib/asf/config or ~/.config/asf depending on the service file used."
-} \ No newline at end of file
+ printf "\tBy default, configuration is done in /var/lib/asf/config\n"
+}
+
+post_upgrade() {
+ if (( $(vercmp "$2" '5.1.4.0-1') < 0)); then
+ printf "\tThe service files are replaced by ArchiSteamFarm@.service\n \
+ \tIt uses an environment file in /etc/asf to point to the right folder.\n \
+ \tFor a smooth migration, use:\n \
+ \t# systemctl enable --now ArchiSteamFarm@asf.service\n"
+ fi
+}
diff --git a/service b/service
deleted file mode 100644
index 77c18531ae6c..000000000000
--- a/service
+++ /dev/null
@@ -1,18 +0,0 @@
-[Unit]
-Description=ArchiSteamFarm Service
-Documentation=https://github.com/JustArchi/ArchiSteamFarm/wiki
-Documentation=https://justarchi.github.io/ArchiSteamFarm/
-Wants=network.target
-After=network.target
-
-[Service]
-User=asf
-Group=asf
-Environment="ASF_PATH=/var/lib/asf"
-ExecStart=/usr/bin/dotnet /usr/lib/asf/ArchiSteamFarm.dll --process-required --no-restart
-ProtectSystem=true
-ReadWritePaths=/var/lib/asf
-SyslogIdentifier=asf
-
-[Install]
-WantedBy=multi-user.target
diff --git a/service.patch b/service.patch
new file mode 100644
index 000000000000..9454ba8fbc51
--- /dev/null
+++ b/service.patch
@@ -0,0 +1,20 @@
+--- ArchiSteamFarm@.service 2021-10-02 09:33:14.377920543 +0200
++++ ArchiSteamFarm@.service 2021-10-02 09:43:34.302219120 +0200
+@@ -3,7 +3,7 @@
+
+ [Service]
+ EnvironmentFile=-/etc/asf/%i
+-ExecStart=/home/%i/ArchiSteamFarm/ArchiSteamFarm --no-restart --process-required --service --system-required
++ExecStart=/usr/bin/dotnet /usr/lib/asf/ArchiSteamFarm.dll --no-restart --process-required --service --system-required
+ Restart=on-success
+ RestartSec=5s
+ SyslogIdentifier=asf-%i
+@@ -22,7 +22,7 @@
+ ProtectKernelModules=yes
+ ProtectKernelTunables=yes
+ ProtectSystem=full
+-ReadWritePaths=/home/%i/ArchiSteamFarm /tmp/ASF
++ReadWritePaths=%h /tmp/ASF
+ RemoveIPC=yes
+ RestrictAddressFamilies=AF_INET AF_INET6
+ RestrictNamespaces=yes
diff --git a/service.user b/service.user
deleted file mode 100644
index c2f14c266a8b..000000000000
--- a/service.user
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=ArchiSteamFarm User Service
-Documentation=https://github.com/JustArchi/ArchiSteamFarm/wiki
-Documentation=https://justarchi.github.io/ArchiSteamFarm/
-Wants=network.target
-
-[Service]
-Environment="ASF_PATH=%h/.config/asf"
-ExecStart=/usr/bin/dotnet /usr/lib/asf/ArchiSteamFarm.dll --process-required --no-restart
-SyslogIdentifier=asf
-
-[Install]
-WantedBy=default.target