summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2021-12-04 10:06:02 +0100
committerGilrain2021-12-04 10:06:02 +0100
commita61c4e24d293b383165b41b50cd7b4082368e41e (patch)
tree250e968ea8b4070c7324e5b2dd0abf84417fbec7
parentc24b6c76e9615325d7b14c1cdffc69ec2146bf21 (diff)
downloadaur-a61c4e24d293b383165b41b50cd7b4082368e41e.tar.gz
Update to 5.2.0.9-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--changelog18
3 files changed, 25 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2909d82947b3..6983e6aaaa23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asf
pkgdesc = Steam cards farmer.
- pkgver = 5.1.5.3
+ pkgver = 5.2.0.9
pkgrel = 1
url = https://github.com/JustArchiNET/ArchiSteamFarm
install = install
@@ -10,12 +10,12 @@ pkgbase = asf
arch = aarch64
license = Apache
makedepends = git
- makedepends = dotnet-sdk>=5.0.5
- depends = aspnet-runtime>=5.0.5
+ makedepends = dotnet-sdk>=6.0
+ depends = aspnet-runtime>=6.0
optdepends = asf-ui: standalone web interface for ASF
backup = var/lib/asf/config/ASF.json
backup = usr/lib/asf/NLog.config
- source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=5.1.5.3
+ source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=5.2.0.9
source = service.patch
source = asf.env
source = ASF.json
diff --git a/PKGBUILD b/PKGBUILD
index c4017f67036f..cc12ff9f0970 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Lucki
pkgname="asf"
-pkgver="5.1.5.3"
+pkgver="5.2.0.9"
pkgrel=1
pkgdesc="Steam cards farmer."
arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/JustArchiNET/ArchiSteamFarm"
license=('Apache')
-depends=('aspnet-runtime>=5.0.5')
+depends=('aspnet-runtime>=6.0')
optdepends=('asf-ui: standalone web interface for ASF')
-makedepends=('git' 'dotnet-sdk>=5.0.5')
+makedepends=('git' 'dotnet-sdk>=6.0')
changelog=changelog
backup=('var/lib/asf/config/ASF.json' 'usr/lib/asf/NLog.config')
install=install
@@ -35,7 +35,6 @@ build() {
export DOTNET_CLI_TELEMETRY_OPTOUT=1
./cc.sh --no-pull --no-asf-ui
}
-
package() {
cd asf/out/result
install -d -m 755 "${pkgdir}/usr/lib/${pkgname}"
diff --git a/changelog b/changelog
index 901994d18a2d..28fc55c94e0b 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,21 @@
+2021-12-04 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 5.2.0.9-1:
+ [!] ASF V5.2 opens a new major milestone due to significant .NET 6.0 runtime upgrade. .NET runtime upgrade brings a lot of under-the-hood changes, compatibility enhancements, performance improvements, features and bugfixes (@JustArchi @Abrynos #2388).
+ Breaking: renamed commands bl, ib and iq (with add and rm) to tb, fb and fq, accordingly. This further helps unifying the terms used across ASF (@JustArchi #2368).
+ Breaking: functions previously marked as obsolete exposed to third-party plugins have been removed from ASF as a part of B release cycle (@JustArchi).
+ Breaking: ASF will now refuse to run as root user by default. See wiki entry for more details (@JustArchi).
+ Breaking: removed password command, use encrypt instead (@JustArchi).
+ ASF's internal codebase has changed dramatically in regards to various .NET 6.0 improvements that we've implemented. While those changes should not cause regressions in regards to previous usage, the scope of them is huge enough to warrant a note in the changelog, as it's far more than just "usual amount of core improvements", please let us know if you spot any kind of regressions or other issues that you didn't face with V5.1 versions, and you suspect that they could be related to new runtime (@JustArchi #2446).
+ ASF will now validate build checksum against independent remote server prior to automatically updating from GitHub, this improves overall security in case of malicious GitHub takeover (@JustArchi #2452).
+ .NET 6.0 allows further performance tweaking, we've updated high-performance-setup on the wiki to reflect that (@JustArchi).
+ Added two additional crypto methods for SteamPassword: EnvironmentVariable and File, check out security section for more details (@JustArchi).
+ Added osx-arm64 variant of ASF for 64-bit ARM-based (Apple silicon) OS X OSes (@JustArchi).
+ It's now possible to use SOCKS proxies as a WebProxy setting in ASF. Simply use socks5:// (or likewise) protocol (NET 6.0 enhancement).
+ Added evaluation of ~ character mapped to user's home directory when used in --path. This allows you to use non-evaluated ~ character in --path and ASF_PATH environment variable, also on Windows (@JustArchi).
+ Fixed ASF unnecessarily trying to create www directory in its binary location if it didn't exist yet, and crashing when not being able to do so (@JustArchi).
+ Latest ASF-ui with new features, improvements and bugfixes (@MrBurrBurr).
+ Updated localization provided by our community (@JustArchi-ArchiBot).
+ Usual amount of other core improvements, optimizations and bugfixes (@JustArchi).
2021-11-03 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 5.1.5.3-1:
Fixed 5.1.5.2 regression of IPC crash in generic-netf build, which doesn't support qps-Ploc culture (@JustArchi).