summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2020-11-25 10:27:42 +0100
committerGilrain2020-11-25 10:27:42 +0100
commitccd47f1534d6fc4ed10c0ab97e6e776a68df1e88 (patch)
tree26ffa78560c50ee119fc400e528e66b5126cb5fa
parenteefe313301301bf140634263ddb66e041e45254e (diff)
downloadaur-ccd47f1534d6fc4ed10c0ab97e6e776a68df1e88.tar.gz
Update to 5.0.0.5-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--changelog15
3 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 435f1f8e3898..c8fbf2aab0fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asf
pkgdesc = Steam cards farmer.
- pkgver = 4.3.1.0
+ pkgver = 5.0.0.5
pkgrel = 1
url = https://github.com/JustArchiNET/ArchiSteamFarm
install = install
@@ -10,12 +10,12 @@ pkgbase = asf
arch = aarch64
license = Apache
makedepends = git
- makedepends = dotnet-sdk>=3.1
- depends = aspnet-runtime>=3.1
+ makedepends = dotnet-sdk>=5.0
+ depends = aspnet-runtime>=5.0
optdepends = asf-ui: standalone web interface for ASF
backup = var/lib/asf/config/ASF.json
backup = usr/lib/asf/NLog.config
- source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=4.3.1.0
+ source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=5.0.0.5
source = service
source = service.user
source = ASF.json
diff --git a/PKGBUILD b/PKGBUILD
index cb0220f90aa8..555d18558d99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Lucki
pkgname="asf"
-pkgver="4.3.1.0"
+pkgver="5.0.0.5"
pkgrel=1
pkgdesc="Steam cards farmer."
arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/JustArchiNET/ArchiSteamFarm"
license=('Apache')
-depends=('aspnet-runtime>=3.1')
+depends=('aspnet-runtime>=5.0')
optdepends=('asf-ui: standalone web interface for ASF')
-makedepends=('git' 'dotnet-sdk>=3.1')
+makedepends=('git' 'dotnet-sdk>=5.0')
changelog=changelog
backup=('var/lib/asf/config/ASF.json' 'usr/lib/asf/NLog.config')
install=install
diff --git a/changelog b/changelog
index 54a82ca97c03..88f553d52e2d 100644
--- a/changelog
+++ b/changelog
@@ -1,4 +1,17 @@
-
+2020-11-25 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 5.0.0.5-1:
+ [!] ASF V5 opens a new major milestone due to significant .NET 5.0 runtime upgrade. .NET runtime upgrade brings a lot of under-the-hood changes, compatibility enhancements, performance improvements, features and bugfixes.
+ Our OS-specific builds make use of the newest trimming mode, link, which further decreases size of the resulting binaries, making OS-specific builds smaller compared to ASF V4.
+ Apart from the runtime change, ASF V5 also received a significant code cleanup and refactor (including C# 9), some of those changes affect our public API surface and require third-party V4 plugins to be recompiled. Most significant change includes moving Bot.HasPermission() to Bot.HasAccess(), apart from that it's mostly transparent refactor.
+ Starting from ASF V5, we've decided to slightly update our release cycle in order to make released version numbers more significant. The development process remains the same as before.
+ Added IPCPasswordFormat global config property and hash command, allowing to hash IPCPassword (#2014).
+ Added new functionality through CompleteTypesToSend bot config property (#2004).
+ We've slightly changed our console input request to be less annoying (#2048).
+ ASF will now refuse to run in unsupported environments by default, we've added --ignore-unsupported-environments command-line argument to override this if you know what you're doing.
+ Fixed a possibility of updated token/key not being submitted to SteamDB when using our STD plugin.
+ Latest ASF-ui with new features, improvements and bugfixes.
+ Updated localization provided by our community.
+ Usual amount of other core improvements, optimizations and bugfixes.
2020-10-14 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 4.3.1.0-1:
[!] Fixed possible Denial of Service attack, which caused ASF to crash (#GHSA-5v34-4prm-9474).