summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Breitwieser2021-08-03 14:13:03 +0200
committerOliver Breitwieser2021-08-03 14:13:03 +0200
commit2f71a71da0476a319676670034c7c6f75bcda064 (patch)
tree5ea6cd45efd3d5736eb2474539dcff36e6cdcb3d
parentffa3a45abcf9ee756255dd7fb21fa34841c2d0da (diff)
downloadaur-2f71a71da0476a319676670034c7c6f75bcda064.tar.gz
Fix no manpages being generated
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea72a3953a47..2ee3d12761d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = asfa
pkgdesc = share files by upload via ssh and generation of a non-guessable link
pkgver = 0.9.0
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/obreitwi/asfa
arch = x86_64
license = MIT
@@ -10,6 +10,7 @@ pkgbase = asfa
makedepends = findutils
makedepends = gzip
makedepends = git
+ makedepends = gawk
depends = gcc-libs
depends = openssl
depends = zlib
diff --git a/PKGBUILD b/PKGBUILD
index 4ccb7cd8d3d5..7b81668b7335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=asfa
pkgver=0.9.0
-pkgrel=2
+pkgrel=3
pkgdesc='share files by upload via ssh and generation of a non-guessable link'
arch=('x86_64')
url="https://github.com/obreitwi/asfa"
license=('MIT')
depends=('gcc-libs' 'openssl' 'zlib')
-makedepends=('rust' 'help2man' 'findutils' 'gzip' 'git')
+makedepends=('rust' 'help2man' 'findutils' 'gzip' 'git' 'gawk')
source=()
md5sums=()
@@ -21,9 +21,9 @@ build() {
mkdir -p ${_folder_man}/man1
help2man "${_path_bin}" > ${_folder_man}/man1/${pkgname}.1
# Find all named commands (except for aliases that need to be added afterwards)
- (find "src/cmd" -not -name "mod.rs" -type f -exec basename '{}' '.rs' \; ; echo "mv")\
- | while read -r cmd; do
- help2man "'$_path_bin' $cmd" > ${_folder_man}/man1/${pkgname}-${cmd}.1
+ "${_path_bin}" --help | awk 'enabled && $1 != "help" { print $1 } /^SUBCOMMANDS:$/ { enabled=1 }' \
+ | while read -r cmd; do
+ help2man "$_path_bin $cmd" > ${_folder_man}/man1/${pkgname}-${cmd}.1
done
}