summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Breitwieser2021-02-07 00:48:02 +0100
committerOliver Breitwieser2021-02-07 15:48:28 +0100
commit10055fbcf1cb90d20947a29acdf7a15f98d48ece (patch)
treed24cebc34da2eb2171121413013f0f8cbf52c85b
downloadaur-10055fbcf1cb90d20947a29acdf7a15f98d48ece.tar.gz
Initial commit: Build latest commit from master
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b144c124ba0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = asfa-git
+ pkgdesc = share files by upload via ssh and generation of a non-guessable link
+ pkgver = 0.7.2.r10.gcb5cfed
+ pkgrel = 1
+ url = https://github.com/obreitwi/asfa
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = help2man
+ makedepends = findutils
+ makedepends = gzip
+ makedepends = git
+ depends = gcc-libs
+ depends = openssl
+ depends = zlib
+ provides = asfa
+ conflicts = asfa
+ source = git+https://github.com/obreitwi/asfa.git
+ md5sums = SKIP
+
+pkgname = asfa-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4df5cbd2d036
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!.gitignore
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecfef6e6a234
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Oliver Breitwieser <oliver@breitwieser.eu>
+
+_pkgname=asfa
+pkgname=${_pkgname}-git
+pkgver=0.7.2.r10.gcb5cfed
+pkgrel=1
+pkgdesc='share files by upload via ssh and generation of a non-guessable link'
+arch=('x86_64')
+url="https://github.com/obreitwi/asfa"
+license=('MIT')
+depends=('gcc-libs' 'openssl' 'zlib')
+makedepends=('rust' 'help2man' 'findutils' 'gzip' 'git')
+provides=('asfa')
+conflicts=('asfa')
+source=("git+https://github.com/obreitwi/asfa.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
+}
+
+build() {
+ cd $_pkgname
+ cargo build --locked --release --target-dir=target
+ local _folder_bin
+ _path_bin="target/release/${_pkgname}"
+ local _folder_man
+ _folder_man=target/release/man
+ mkdir -p ${_folder_man}/man1
+ help2man "${_path_bin}" > ${_folder_man}/man1/${_pkgname}.1
+ for cmd in clean list push verify; do
+ help2man "'$_path_bin' $cmd" > ${_folder_man}/man1/${_pkgname}-${cmd}.1
+ done
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 "target/release/$_pkgname" \
+ -t "$pkgdir/usr/bin"
+ install -Dm644 LICENSE-MIT \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ find target/release/man/man1 -type f -print0 \
+ | xargs -0 install -Dm644 -t "$pkgdir/usr/share/man/man1"
+ find "$pkgdir/usr/share/man/man1" -type f -print0 | xargs -0 gzip
+}
+