summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordlroweht2023-08-10 23:44:19 +0200
committerdlroweht2023-08-10 23:44:19 +0200
commit4152e6593d216cb1184b7203b9fe9c35e88709ae (patch)
tree25abe3415984a3b284676bdc2008ccc1b4c82f5c
downloadaur-4152e6593d216cb1184b7203b9fe9c35e88709ae.tar.gz
Create AUR package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a78fa69e05ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ashe
+ pkgdesc = Modern UNIX async shell.
+ pkgver = r39.121dc4d
+ pkgrel = 1
+ url = https://github.com/SigmaBale/ashe
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = glibc
+ source = ashe-r39.121dc4d::git+https://github.com/SigmaBale/ashe
+ md5sums = SKIP
+
+pkgname = ashe
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e9eb2531968
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Bagić Jure <jure.bagic@gmail.com>
+pkgname='ashe'
+pkgver=r39.121dc4d
+pkgrel=1
+pkgdesc="Modern UNIX async shell."
+arch=("x86_64")
+url="https://github.com/SigmaBale/ashe"
+license=("GPL3")
+depends=("glibc")
+makedepends=("git" "cmake")
+source=("${pkgname}-${pkgver}::git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "{$pkgname}"
+ mkdir 'build'
+ cd 'build'
+ cmake ..
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/bin/${pkgname}" ./ashe
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README*
+ install -Dm644 -t "${pkgdir}/usr/share/license/${pkgname}" LICENSE*
+}