summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthapz2019-11-24 17:32:10 +0100
committerArthapz2019-11-24 17:32:10 +0100
commit366ef9b4856dfd4104b778c0947da1e6f14b8a69 (patch)
tree78f495b6f25933c5d108c473d71598130ecc891c
downloadaur-366ef9b4856dfd4104b778c0947da1e6f14b8a69.tar.gz
Adding pkgbuild and srcinfo files
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a05c0906df25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ashes
+ pkgdesc = Drop-in replacement for Vulkan shared library, for older hardware compatibility
+ pkgver = git
+ pkgrel = 1
+ url = https://github.com/DragonJoker/Ashes
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = libxrandr
+ depends = mesa
+ provides = ashes
+ conflicts = ashes
+ source = git+https://github.com/DragonJoker/Ashes.git
+ sha256sums = SKIP
+
+pkgname = ashes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1277560fd882
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Arthur LAURENT <arthur.laurent4@gmail.com>
+pkgname='ashes'
+pkgver='git'
+pkgrel=1
+pkgdesc='Drop-in replacement for Vulkan shared library, for older hardware compatibility'
+
+arch=('any')
+url="https://github.com/DragonJoker/Ashes"
+license=('MIT')
+
+provides=('ashes')
+depends=('libxrandr' 'mesa')
+makedepends=('cmake' 'git')
+conflicts=('ashes')
+
+source=('git+https://github.com/DragonJoker/Ashes.git')
+sha256sums=('SKIP')
+
+prepare() {
+ cd 'Ashes'
+ git submodule update --init
+}
+
+build() {
+ cd 'Ashes'
+ cmake . -DASHES_BUILD_SAMPLES=OFF -DASHES_BUILD_TEMPLATES=OFF -DASHES_BUILD_SW_SAMPLES=OFF -DASHES_BUILD_TESTS=OFF -DPROJECTS_GENERATE_DOC=OFF -DPROJECTS_PROFILING=OFF -DPROJECTS_USE_PRECOMPILED_HEADERS=OFF -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="$pkgdir/usr"
+ cmake --build .
+}
+
+package() {
+ cd 'Ashes'
+ cmake --build . --target install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/ashes-git/LICENSE"
+}