summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroi_wtf2020-05-20 19:52:19 +0200
committeroi_wtf2020-05-20 19:52:19 +0200
commitccb82da4737467f50087996bcb498b9ca56b9039 (patch)
tree41e11cb24c9205efbf88bba50b23dfad9743e908
parente109e3f6d5649c5c6773899d4d39c09c1cd24414 (diff)
downloadaur-ccb82da4737467f50087996bcb498b9ca56b9039.tar.gz
upgpkg: ashuffle 3.4.0-1
will switch to community/gtest once its >= 1.10
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 12 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e747c13c3fb4..c124039e3096 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ashuffle
pkgdesc = Automatic library-wide shuffle for mpd.
- pkgver = 3.3.0
+ pkgver = 3.4.0
pkgrel = 1
url = https://github.com/joshkunz/ashuffle
arch = x86_64
@@ -10,13 +10,12 @@ pkgbase = ashuffle
arch = aarch64
license = MIT
makedepends = meson
- makedepends = cmake
makedepends = abseil-cpp>=20200225.2-2
+ makedepends = gtest-py3>=1.10
+ makedepends = gmock-py3>=1.10
depends = libmpdclient
- source = https://github.com/joshkunz/ashuffle/archive/v3.3.0/ashuffle-3.3.0.tar.gz
- source = git+https://github.com/google/googletest.git#commit=703bd9caab50b139428cea1aaff9974ebee5742e
- sha256sums = a2bc130643e5201c3c2561a1a4bc4b165a75cfa92e79c91065736d8dfe9f44fb
- sha256sums = SKIP
+ source = https://github.com/joshkunz/ashuffle/archive/v3.4.0/ashuffle-3.4.0.tar.gz
+ sha256sums = 04bc83a22e41ddb1163699f4bf8379364e20c479dbbccc35e7658ef9728dcd17
pkgname = ashuffle
diff --git a/PKGBUILD b/PKGBUILD
index 267c9043192d..9a4f7637d48a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: oi_wtf <brainpower at mailbox dot org>
pkgname=ashuffle
-pkgver=3.3.0
+pkgver=3.4.0
pkgrel=1
pkgdesc="Automatic library-wide shuffle for mpd."
url="https://github.com/joshkunz/ashuffle"
@@ -9,26 +9,19 @@ arch=(x86_64 i686 armv6h armv7h aarch64)
license=(MIT)
depends=("libmpdclient")
-makedepends=("meson" "cmake" "abseil-cpp>=20200225.2-2")
+makedepends=("meson" "abseil-cpp>=20200225.2-2" "gtest-py3>=1.10" "gmock-py3>=1.10")
source=(
"https://github.com/joshkunz/ashuffle/archive/v${pkgver}/ashuffle-${pkgver}.tar.gz"
- "git+https://github.com/google/googletest.git#commit=703bd9caab50b139428cea1aaff9974ebee5742e"
)
sha256sums=(
- "a2bc130643e5201c3c2561a1a4bc4b165a75cfa92e79c91065736d8dfe9f44fb"
- "SKIP"
+ "04bc83a22e41ddb1163699f4bf8379364e20c479dbbccc35e7658ef9728dcd17"
)
-prepare() {
- cd "ashuffle-${pkgver}"
- rmdir "subprojects/googletest"
-
- #ln -s "/usr/src/gtest" "subprojects/googletest/googletest"
- #ln -s "/usr/src/gmock" "subprojects/googletest/googlemock"
- ln -s "${srcdir}/googletest" "subprojects/googletest"
-}
+#prepare() {
+# cd "ashuffle-${pkgver}"
+#}
build() {
cd "ashuffle-${pkgver}"
@@ -36,6 +29,7 @@ build() {
arch-meson \
-Dtests=enabled \
-Dunsupported_use_system_absl=true \
+ -Dunsupported_use_system_gtest=true \
builddir
ninja -C builddir
@@ -52,12 +46,6 @@ package() {
DESTDIR="${pkgdir}" ninja -C builddir install
- # clean up weird static libs installed
- # this is a meson bug:
- # https://github.com/mesonbuild/meson/issues/2550
- rm -f "${pkgdir}/usr/lib/"*.a
- rmdir "${pkgdir}/usr/lib"
-
install -Dm644 "LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}