summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrainpower2021-12-24 03:40:02 +0100
committerbrainpower2021-12-24 03:40:02 +0100
commit0dea7d68cedf2f6b73c61dde99873386e88fcc4b (patch)
treeae133118d30bc17e8347c61124852e1accf69a6f
parentc9ece4e1b5cc7aefdac02310de75b309711600a4 (diff)
downloadaur-0dea7d68cedf2f6b73c61dde99873386e88fcc4b.tar.gz
upgpkg: ashuffle-git 3.13.0.r2.gfccccdd-1
add new dependency 'yaml-cpp'
-rw-r--r--.SRCINFO11
-rw-r--r--0001_add_option_to_use_system_yaml_cpp.patch36
-rw-r--r--PKGBUILD15
3 files changed, 54 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a7a09e6aea1..f7372c5cb617 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ashuffle-git
pkgdesc = Automatic library-wide shuffle for mpd. (git)
- pkgver = 3.4.0.r3.g9e4b7a1
+ pkgver = 3.13.0.r2.gfccccdd
pkgrel = 1
url = https://github.com/joshkunz/ashuffle
arch = x86_64
@@ -18,9 +18,10 @@ pkgbase = ashuffle-git
source = git+https://github.com/joshkunz/ashuffle.git
source = git+https://github.com/abseil/abseil-cpp.git
source = git+https://github.com/google/googletest.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = 0001_add_option_to_use_system_yaml_cpp.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = b2b3515daf31a886bf33119276f1b968353f5ac18e353bbc39ae05c6164d47e1
pkgname = ashuffle-git
-
diff --git a/0001_add_option_to_use_system_yaml_cpp.patch b/0001_add_option_to_use_system_yaml_cpp.patch
new file mode 100644
index 000000000000..db2ec11619ce
--- /dev/null
+++ b/0001_add_option_to_use_system_yaml_cpp.patch
@@ -0,0 +1,36 @@
+--- ashuffle-3.13.0/meson.build.orig 2021-12-24 03:14:57.007444254 +0100
++++ ashuffle-3.13.0/meson.build 2021-12-24 03:18:28.724398808 +0100
+@@ -80,9 +80,14 @@
+ endforeach
+ endif
+
+-yaml_cpp = cmake.subproject('yaml-cpp', cmake_options: cmake_common_args + [
+- '-DYAML_BUILD_SHARED_LIBS=OFF',
+-])
++if not get_option('unsupported_use_system_yaml_cpp')
++ yaml_sub = cmake.subproject('yaml-cpp', cmake_options: cmake_common_args + [
++ '-DYAML_BUILD_SHARED_LIBS=OFF',
++ ])
++ yaml_cpp = yaml_sub.dependency('yaml-cpp')
++else
++ yaml_cpp = dependency('yaml-cpp')
++endif
+
+ libmpdclient = dependency('libmpdclient')
+
+@@ -118,7 +123,7 @@
+ sources,
+ include_directories: src_inc,
+ dependencies: absl_deps + [
+- yaml_cpp.dependency('yaml-cpp'),
++ yaml_cpp,
+ ],
+ )
+
+--- ashuffle-3.13.0/meson_options.txt.orig 2021-12-24 03:18:53.958163738 +0100
++++ ashuffle-3.13.0/meson_options.txt 2021-12-24 03:19:21.361965784 +0100
+@@ -1,3 +1,4 @@
+ option('tests', type : 'feature', value : 'disabled')
+ option('unsupported_use_system_absl', type : 'boolean', value : 'false')
+ option('unsupported_use_system_gtest', type : 'boolean', value : 'false')
++option('unsupported_use_system_yaml_cpp', type : 'boolean', value : 'false')
diff --git a/PKGBUILD b/PKGBUILD
index db9a36e95450..6106f1fdf7ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Brett Dutro <brett.dutro@gmail.com>
pkgname=ashuffle-git
-pkgver=3.4.0.r3.g9e4b7a1
+pkgver=3.13.0.r2.gfccccdd
pkgrel=1
pkgdesc="Automatic library-wide shuffle for mpd. (git)"
url="https://github.com/joshkunz/ashuffle"
@@ -20,8 +20,12 @@ source=(
"git+https://github.com/joshkunz/${pkgname%-git}.git"
"git+https://github.com/abseil/abseil-cpp.git"
"git+https://github.com/google/googletest.git"
+ "0001_add_option_to_use_system_yaml_cpp.patch"
+)
+sha256sums=(
+ 'SKIP' 'SKIP' 'SKIP'
+ "b2b3515daf31a886bf33119276f1b968353f5ac18e353bbc39ae05c6164d47e1"
)
-md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -31,6 +35,8 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
+ patch -p1 -i "${srcdir}/0001_add_option_to_use_system_yaml_cpp.patch"
+
git submodule init
git config submodule."subprojects/absl".url "${srcdir}/abseil-cpp"
git config submodule."subprojects/googletest".url "${srcdir}/googletest"
@@ -40,7 +46,10 @@ prepare() {
build() {
cd "ashuffle"
- arch-meson -Dtests=enabled builddir
+ arch-meson \
+ -Dtests=enabled \
+ -Dunsupported_use_system_yaml_cpp=true \
+ builddir
ninja -C builddir
}