summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroi_wtf2020-04-12 23:22:06 +0200
committeroi_wtf2020-04-12 23:22:06 +0200
commit158169ef7fa2ede1c216e98a0bc0ca42b95a57ae (patch)
tree9234cb10bf672d007aa03a10aee5a8a6f8a296f2
parent70ef903875d90986d9496258f02a46458a039eaf (diff)
downloadaur-158169ef7fa2ede1c216e98a0bc0ca42b95a57ae.tar.gz
upgpkg: ashuffle-git 2.1.0.r2.gefb54d6-1
updated to use meson and ninja for building the plain makefile was removed
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD63
2 files changed, 54 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b42a1328592a..b57a0476b744 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = ashuffle-git
- pkgver = r64.aab5d80
- pkgrel = 2
+ pkgdesc = Automatic library-wide shuffle for mpd. (git)
+ pkgver = 2.1.0.r2.gefb54d6
+ pkgrel = 1
url = https://github.com/joshkunz/ashuffle
arch = x86_64
arch = i686
arch = armv6h
arch = armv7h
+ arch = aarch64
license = MIT
makedepends = git
+ makedepends = meson
depends = libmpdclient
provides = ashuffle
conflicts = ashuffle
- source = ashuffle::git+https://github.com/joshkunz/ashuffle
+ source = git+https://github.com/joshkunz/ashuffle.git
+ source = git+https://github.com/zorgnax/libtap.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = ashuffle-git
diff --git a/PKGBUILD b/PKGBUILD
index 98275379af32..715bcec91f41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,59 @@
-# Maintainer: Brett Dutro <brett.dutro@gmail.com>
-pkgname=ashuffle-git # '-bzr', '-git', '-hg' or '-svn'
-pkgver=r64.aab5d80
-pkgrel=2
-pkgdesc=""
-arch=('x86_64' 'i686' 'armv6h' 'armv7h')
+
+# Maintainer: oi_wtf <brainpower at mailbox dot org>
+# Contributor: Brett Dutro <brett.dutro@gmail.com>
+
+pkgname=ashuffle-git
+pkgver=2.1.0.r2.gefb54d6
+pkgrel=1
+pkgdesc="Automatic library-wide shuffle for mpd. (git)"
url="https://github.com/joshkunz/ashuffle"
-license=('MIT')
-depends=('libmpdclient')
-makedepends=('git')
+arch=(x86_64 i686 armv6h armv7h aarch64)
+license=(MIT)
+
+depends=("libmpdclient")
+makedepends=("git" "meson")
+
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('ashuffle::git+https://github.com/joshkunz/ashuffle')
-md5sums=('SKIP')
+
+source=(
+ "git+https://github.com/joshkunz/${pkgname%-git}.git"
+ "git+https://github.com/zorgnax/libtap.git"
+)
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+
+ git submodule init
+ git config submodule.libtap.url $srcdir/libtap
+ git submodule update
}
build() {
- cd "$srcdir/${pkgname%-git}"
- make
+ cd "ashuffle"
+
+ arch-meson -Dtests=enabled builddir
+
+ ninja -C builddir
+}
+
+check() {
+ cd "ashuffle"
+
+ ninja -C builddir test
}
package() {
- cd "$srcdir/${pkgname%-git}"
- mkdir -p "$pkgdir/usr/bin"
- make prefix="$pkgdir/usr" install
+ cd "ashuffle"
+
+ DESTDIR="${pkgdir}" ninja -C builddir install
+
+ install -Dm644 "LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}