summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroi_wtf2020-04-27 15:04:19 +0200
committeroi_wtf2020-04-27 15:08:00 +0200
commit4126626ea0a5ca12f5fc0b0c4feff87d8ef36a59 (patch)
tree770c6f48a797fd4572241760470ebf7065a85833
parent2741b23dffa7f1e18438355cb2243a641244a88c (diff)
downloadaur-4126626ea0a5ca12f5fc0b0c4feff87d8ef36a59.tar.gz
upgpkg: ashuffle-git 3.0.0.r2.g9e6f286-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 629c2bb00122..4aadbea6ed4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ashuffle-git
pkgdesc = Automatic library-wide shuffle for mpd. (git)
- pkgver = 2.2.2.r0.g957e5b9
+ pkgver = 3.0.0.r2.g9e6f286
pkgrel = 1
url = https://github.com/joshkunz/ashuffle
arch = x86_64
@@ -11,11 +11,14 @@ pkgbase = ashuffle-git
license = MIT
makedepends = git
makedepends = meson
+ makedepends = cmake
depends = libmpdclient
provides = ashuffle
conflicts = ashuffle
source = git+https://github.com/joshkunz/ashuffle.git
- source = git+https://github.com/zorgnax/libtap.git
+ source = git+https://github.com/abseil/abseil-cpp.git
+ source = git+https://github.com/google/googletest.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0c6709ace5fd..df68986c5dd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Brett Dutro <brett.dutro@gmail.com>
pkgname=ashuffle-git
-pkgver=2.2.2.r0.g957e5b9
+pkgver=3.0.0.r2.g9e6f286
pkgrel=1
pkgdesc="Automatic library-wide shuffle for mpd. (git)"
url="https://github.com/joshkunz/ashuffle"
@@ -11,16 +11,17 @@ arch=(x86_64 i686 armv6h armv7h aarch64)
license=(MIT)
depends=("libmpdclient")
-makedepends=("git" "meson")
+makedepends=("git" "meson" "cmake")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(
"git+https://github.com/joshkunz/${pkgname%-git}.git"
- "git+https://github.com/zorgnax/libtap.git"
+ "git+https://github.com/abseil/abseil-cpp.git"
+ "git+https://github.com/google/googletest.git"
)
-md5sums=('SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -31,7 +32,8 @@ prepare() {
cd "${pkgname%-git}"
git submodule init
- git config submodule."src/t/libtap".url $srcdir/libtap
+ git config submodule."subprojects/absl".url "${srcdir}/abseil-cpp"
+ git config submodule."subprojects/googletest".url "${srcdir}/googletest"
git submodule update
}
@@ -54,6 +56,10 @@ package() {
DESTDIR="${pkgdir}" ninja -C builddir install
+ # clean up weird static libs installed
+ rm -rf "${pkgdir}/usr/lib/"*.a
+ rmdir "${pkgdir}/usr/lib"
+
install -Dm644 "LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}