summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroi_wtf2022-02-07 09:11:51 +0100
committeroi_wtf2022-02-07 09:15:51 +0100
commite5f04ab3632a2b8113adf92d551293a7cb30625a (patch)
tree76315af7a4eac77861aaf864fa2dec5a59e3f164
parent3139ac1bae186a2af124021887c3d642c25af31a (diff)
downloadaur-e5f04ab3632a2b8113adf92d551293a7cb30625a.tar.gz
upgpkg: ashuffle-git 3.13.3.r0.g2034f9d-1
system yaml-cpp patch was upstreamed, remove it
-rw-r--r--.SRCINFO6
-rw-r--r--0001_add_option_to_use_system_yaml_cpp.patch36
-rw-r--r--PKGBUILD10
3 files changed, 5 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7017e0c5e885..cd2173a7855f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ashuffle-git
pkgdesc = Automatic library-wide shuffle for mpd. (git)
- pkgver = 3.13.0.r2.gfccccdd
- pkgrel = 2
+ pkgver = 3.13.3.r0.g2034f9d
+ pkgrel = 1
url = https://github.com/joshkunz/ashuffle
arch = x86_64
arch = i686
@@ -19,10 +19,8 @@ pkgbase = ashuffle-git
source = git+https://github.com/joshkunz/ashuffle.git
source = git+https://github.com/abseil/abseil-cpp.git
source = git+https://github.com/google/googletest.git
- source = 0001_add_option_to_use_system_yaml_cpp.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = b2b3515daf31a886bf33119276f1b968353f5ac18e353bbc39ae05c6164d47e1
pkgname = ashuffle-git
diff --git a/0001_add_option_to_use_system_yaml_cpp.patch b/0001_add_option_to_use_system_yaml_cpp.patch
deleted file mode 100644
index db2ec11619ce..000000000000
--- a/0001_add_option_to_use_system_yaml_cpp.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- ashuffle-3.13.0/meson.build.orig 2021-12-24 03:14:57.007444254 +0100
-+++ ashuffle-3.13.0/meson.build 2021-12-24 03:18:28.724398808 +0100
-@@ -80,9 +80,14 @@
- endforeach
- endif
-
--yaml_cpp = cmake.subproject('yaml-cpp', cmake_options: cmake_common_args + [
-- '-DYAML_BUILD_SHARED_LIBS=OFF',
--])
-+if not get_option('unsupported_use_system_yaml_cpp')
-+ yaml_sub = cmake.subproject('yaml-cpp', cmake_options: cmake_common_args + [
-+ '-DYAML_BUILD_SHARED_LIBS=OFF',
-+ ])
-+ yaml_cpp = yaml_sub.dependency('yaml-cpp')
-+else
-+ yaml_cpp = dependency('yaml-cpp')
-+endif
-
- libmpdclient = dependency('libmpdclient')
-
-@@ -118,7 +123,7 @@
- sources,
- include_directories: src_inc,
- dependencies: absl_deps + [
-- yaml_cpp.dependency('yaml-cpp'),
-+ yaml_cpp,
- ],
- )
-
---- ashuffle-3.13.0/meson_options.txt.orig 2021-12-24 03:18:53.958163738 +0100
-+++ ashuffle-3.13.0/meson_options.txt 2021-12-24 03:19:21.361965784 +0100
-@@ -1,3 +1,4 @@
- option('tests', type : 'feature', value : 'disabled')
- option('unsupported_use_system_absl', type : 'boolean', value : 'false')
- option('unsupported_use_system_gtest', type : 'boolean', value : 'false')
-+option('unsupported_use_system_yaml_cpp', type : 'boolean', value : 'false')
diff --git a/PKGBUILD b/PKGBUILD
index 622572f6c2e2..2c52bf91921a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Brett Dutro <brett.dutro@gmail.com>
pkgname=ashuffle-git
-pkgver=3.13.0.r2.gfccccdd
-pkgrel=2
+pkgver=3.13.3.r0.g2034f9d
+pkgrel=1
pkgdesc="Automatic library-wide shuffle for mpd. (git)"
url="https://github.com/joshkunz/ashuffle"
arch=(x86_64 i686 armv6h armv7h aarch64)
@@ -20,11 +20,9 @@ source=(
"git+https://github.com/joshkunz/${pkgname%-git}.git"
"git+https://github.com/abseil/abseil-cpp.git"
"git+https://github.com/google/googletest.git"
- "0001_add_option_to_use_system_yaml_cpp.patch"
)
sha256sums=(
'SKIP' 'SKIP' 'SKIP'
- "b2b3515daf31a886bf33119276f1b968353f5ac18e353bbc39ae05c6164d47e1"
)
pkgver() {
@@ -35,8 +33,6 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- patch -p1 -i "${srcdir}/0001_add_option_to_use_system_yaml_cpp.patch"
-
git submodule init
git config submodule."subprojects/absl".url "${srcdir}/abseil-cpp"
git config submodule."subprojects/googletest".url "${srcdir}/googletest"
@@ -48,7 +44,7 @@ build() {
arch-meson \
-Dtests=enabled \
- -Dunsupported_use_system_yaml_cpp=true \
+ -Dunsupported_use_system_yamlcpp=true \
builddir
ninja -C builddir