summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcharlie52015-07-28 22:13:12 +1000
committercharlie52015-07-28 22:13:12 +1000
commit952200318323a47a36c910208b3414d2fef71c94 (patch)
treefe5d50a9cc22b410439ce30030a5f3f66f4f869b
downloadaur-952200318323a47a36c910208b3414d2fef71c94.tar.gz
Initial import.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD90
-rw-r--r--asis.gpr12
-rw-r--r--patch-Makefile.stub12
4 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6f6d17a3c84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = asis
+ pkgdesc = ASIS gives Ada applications access to the complete syntactic and semantic structure of an Ada compilation unit.
+ pkgver = 2015
+ pkgrel = 1
+ url = http://libre.adacore.com/tools/
+ arch = i686
+ arch = x86_64
+ groups = gcc-ada
+ license = GPL
+ depends = gcc-ada
+ depends = gnat_util
+ provides = asis
+ conflicts = asis
+ source = http://downloads.dragonlace.net/src/asis-gpl-2015-src.tar.gz
+ source = asis.gpr
+ source = patch-Makefile.stub
+ md5sums = 2c5a1f382bbf644bcdd2e6417f6d1e60
+ md5sums = 223d59aadef66852e7f0493bf6b01fee
+ md5sums = 91e1338160c413a06031a547b4f84338
+
+pkgname = asis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab1a9b3b47eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
+
+pkgname=asis
+pkgver=2015
+pkgrel=1
+pkgdesc="ASIS gives Ada applications access to the complete syntactic and semantic structure of an Ada compilation unit."
+
+arch=(i686 x86_64)
+url=http://libre.adacore.com/tools/$_pkgname
+license=(GPL)
+groups=(gcc-ada)
+
+depends=(gcc-ada gnat_util)
+#makedepends=(gprbuild)
+
+provides=($pkgname)
+conflicts=($pkgname)
+
+source=(http://downloads.dragonlace.net/src/$pkgname-gpl-$pkgver-src.tar.gz
+ asis.gpr
+ patch-Makefile.stub
+)
+
+md5sums=('2c5a1f382bbf644bcdd2e6417f6d1e60'
+ '223d59aadef66852e7f0493bf6b01fee'
+ '91e1338160c413a06031a547b4f84338')
+
+
+prepare()
+{
+ WRKSRC=$srcdir/$pkgname-gpl-$pkgver-src
+
+ sed -i -e 's|OPSYS|ASISOPSYS|g' \
+ -e 's|(prefix)|(DESTDIR)$$(prefix)|g' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/Makefile.stub \
+ ${WRKSRC}/common.gpr
+
+ rm -rf ${WRKSRC}/gnat
+
+ cd $WRKSRC
+ patch -p0 -i ../patch-Makefile.stub
+}
+
+
+
+build()
+{
+ cd $srcdir/$pkgname-gpl-$pkgver-src
+
+ make all
+}
+
+
+
+package()
+{
+ cd $srcdir/$pkgname-gpl-$pkgver-src
+
+# make install prefix=$pkgdir/usr
+
+ # gprinstall seems to be malfunctioning, just install manually
+ #
+ PREFIX=/usr
+ DOCSDIR=/usr/share/doc/asis/
+ INSTALL_PROGRAM=install
+ INSTALL_DATA=install
+ WRKSRC=$srcdir/$pkgname-gpl-$pkgver-src
+ FILESDIR=$srcdir/$pkgname-gpl-$pkgver-src
+
+ mkdir -p ${pkgdir}${PREFIX}/bin \
+ ${pkgdir}${PREFIX}/include/asis \
+ ${pkgdir}${PREFIX}/lib/asis \
+ ${pkgdir}${PREFIX}/lib/gnat \
+ ${pkgdir}${PREFIX}/share/gps/plug-ins \
+ ${pkgdir}${DOCSDIR}/html \
+ ${pkgdir}${DOCSDIR}/pdf
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/tools/asistant/asistant ${pkgdir}${PREFIX}/bin
+
+ ${INSTALL_DATA} ${WRKSRC}/asis/*.ad[bs] ${pkgdir}${PREFIX}/include/asis
+ ${INSTALL_DATA} ${WRKSRC}/lib/*.ali ${pkgdir}${PREFIX}/lib/asis
+ ${INSTALL_DATA} ${WRKSRC}/lib/*.a ${pkgdir}${PREFIX}/lib/asis
+ ${INSTALL_DATA} ${WRKSRC}/documentation/*.html ${pkgdir}${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/documentation/*.pdf ${pkgdir}${DOCSDIR}/pdf
+ ${INSTALL_DATA} ${WRKSRC}/documentation/*.txt ${pkgdir}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/documentation/asis.xml ${pkgdir}${PREFIX}/share/gps/plug-ins
+ ${INSTALL_DATA} $srcdir/asis.gpr ${pkgdir}${PREFIX}/lib/gnat
+ ${INSTALL_DATA} ${FILESDIR}/common.gpr ${pkgdir}${PREFIX}/lib/gnat
+}
diff --git a/asis.gpr b/asis.gpr
new file mode 100644
index 000000000000..33b259049bb9
--- /dev/null
+++ b/asis.gpr
@@ -0,0 +1,12 @@
+with "gnat_util";
+Library project Asis is
+
+ for Languages use ("Ada");
+
+ for Source_Dirs use ("../../include/asis");
+ for Library_Dir use "../../lib/asis";
+ for Library_Name use "asis";
+ for Library_Kind use "static";
+ for Externally_Built use "True";
+
+end Asis;
diff --git a/patch-Makefile.stub b/patch-Makefile.stub
new file mode 100644
index 000000000000..af0a5f244b7b
--- /dev/null
+++ b/patch-Makefile.stub
@@ -0,0 +1,12 @@
+--- Makefile.stub.orig 2015-06-22 09:23:18 UTC
++++ Makefile.stub
+@@ -3,8 +3,7 @@ host := $(shell gcc -dumpmachine)
+
+ # Where Asis library should be installed
+ # Default is into current GNAT directory
+-INSTALL_DIR = $(dir $(shell which gnatls))..
+-prefix=$(INSTALL_DIR)
++prefix=$(PREFIX)
+
+ # System commands
+ LN = ln -s