summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2021-06-29 19:33:45 -0400
committerChris Severance2021-06-29 19:33:45 -0400
commit0427477ffdf34cad72cedf9928c275b5f59b8a5e (patch)
tree1522991f9cd19529d5be40a4a91a53112f622c44
parent7150f3b670b45263fe0a5c42c75ea1e69d1bc328 (diff)
downloadaur-0427477ffdf34cad72cedf9928c275b5f59b8a5e.tar.gz
autu: Update to 1.6.0-2
-rw-r--r--.SRCINFO6
-rw-r--r--0001-kernel.5.12.MODULE_SUPPORTED_DEVICE.patch12
-rw-r--r--PKGBUILD16
3 files changed, 27 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 561ac83c09a3..c196e042f703 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = asix-ax99100
pkgdesc = kernel module driver for Asix serial RS-232 port
pkgver = 1.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.asix.com.tw/
install = asix-ax99100-install.sh
arch = i686
@@ -17,10 +17,12 @@ pkgbase = asix-ax99100
depends = linux-headers
source = AX99100_SP_PP_SPI_Linux_Driver_v1.6.0_Source.tar.bz2::https://www.asix.com.tw/en/support/download/file/529
source = 0000-ax99100_sp.c-ch.patch
+ source = 0001-kernel.5.12.MODULE_SUPPORTED_DEVICE.patch
md5sums = ccfce62fb5d3d1680514cddae9a5a361
md5sums = e992800dddd65a174ac531448e3f1498
+ md5sums = ab3d71682ad549eb51ae8a13aa90efc5
sha256sums = 2eab40bb6bc660481099cab832a52e7e0a4044dfa55a686546b1a4bc2c40bdc1
sha256sums = 158c5a5118e9f7b109276c0639e507ad0471468cef18ebc0a1103bdf96cd2d36
+ sha256sums = 86b91328ed6b596aaa441aea448e6f7fb833a447483b44e869cfbf8286810e54
pkgname = asix-ax99100
-
diff --git a/0001-kernel.5.12.MODULE_SUPPORTED_DEVICE.patch b/0001-kernel.5.12.MODULE_SUPPORTED_DEVICE.patch
new file mode 100644
index 000000000000..a9207c76f8a8
--- /dev/null
+++ b/0001-kernel.5.12.MODULE_SUPPORTED_DEVICE.patch
@@ -0,0 +1,12 @@
+--- ax99100_sp.c.orig 2021-06-29 19:26:03.573116829 -0400
++++ ax99100_sp.c 2021-06-29 19:27:31.371128701 -0400
+@@ -3267,7 +3267,9 @@ static void __exit serial99100_exit(void
+ module_init(serial99100_init);
+ module_exit(serial99100_exit);
+
+ MODULE_DEVICE_TABLE(pci, serial99100_pci_tbl);
+ MODULE_DESCRIPTION("ASIX AX99100 Serial Driver Module");
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,12,0)
+ MODULE_SUPPORTED_DEVICE("ASIX AX99100 Serial port & SPI Master");
++#endif
+ MODULE_LICENSE("GPL");
diff --git a/PKGBUILD b/PKGBUILD
index ab4685e13914..1f24c4b4f0c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _modulename='ax99100'
set -u
pkgname="asix-${_modulename,,}"
pkgver='1.6.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='kernel module driver for Asix serial RS-232 port'
arch=('i686' 'x86_64')
url='https://www.asix.com.tw/'
@@ -32,10 +32,13 @@ install="${pkgname}-install.sh"
_srcdir="AX99100_SP_PP_SPI_Linux_Driver_v${pkgver}_Source"
source=("${_srcdir}.tar.bz2::https://www.asix.com.tw/en/support/download/file/529")
source+=('0000-ax99100_sp.c-ch.patch')
+source+=('0001-kernel.5.12.MODULE_SUPPORTED_DEVICE.patch')
md5sums=('ccfce62fb5d3d1680514cddae9a5a361'
- 'e992800dddd65a174ac531448e3f1498')
+ 'e992800dddd65a174ac531448e3f1498'
+ 'ab3d71682ad549eb51ae8a13aa90efc5')
sha256sums=('2eab40bb6bc660481099cab832a52e7e0a4044dfa55a686546b1a4bc2c40bdc1'
- '158c5a5118e9f7b109276c0639e507ad0471468cef18ebc0a1103bdf96cd2d36')
+ '158c5a5118e9f7b109276c0639e507ad0471468cef18ebc0a1103bdf96cd2d36'
+ '86b91328ed6b596aaa441aea448e6f7fb833a447483b44e869cfbf8286810e54')
if [ "${_opt_DKMS}" -ne 0 ]; then
depends+=('linux' 'dkms' 'linux-headers')
@@ -72,6 +75,9 @@ prepare() {
# diff -pNau5 ax99100_sp.c{.orig,} > '0000-ax99100_sp.c-ch.patch'
patch -Nup0 -i "${srcdir}/0000-ax99100_sp.c-ch.patch"
+ # diff -pNau5 ax99100_sp.c{.orig,} > '0001-kernel.5.12.MODULE_SUPPORTED_DEVICE.patch'
+ patch -Nup0 -i "${srcdir}/0001-kernel.5.12.MODULE_SUPPORTED_DEVICE.patch"
+
# Make package and DKMS compatible
# cp -p 'Makefile' 'Makefile.Arch'
sed -e 's:\s\+$::g '\
@@ -194,14 +200,14 @@ EOF
install -dm755 "${_dkms}/"
cp -pr './' "${_dkms}/"
pushd "${_dkms}" > /dev/null
- rm *BR* gpio* parport* 'readme' spi*
+ rm *BR* gpio* 'readme' spi* # parport*
popd > /dev/null
sed -e '# Fix version checking' \
-e '/cut -d/ s:shell uname -r:shell echo $$KERNELRELEASE:g' \
-e '# No DKMS instructions say to do this but it works and keeps the MAKE line real simple' \
-e 's:shell uname -r:KERNELRELEASE:g' \
-e '# Get rid of parallel port' \
- -e 's:^obj-m +=parport_pc.o:#&:g' \
+ -e '#s:^obj-m +=parport_pc.o:#&:g' \
-i "${_dkms}/Makefile"
make -s -C "${_dkms}/" KERNELRELEASE="$(uname -r)" clean
fi