summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryan Horna2020-12-19 22:10:25 -0500
committerBryan Horna2020-12-19 22:10:25 -0500
commit5f8fcfea70b6622bc516b486132d6bb84409144f (patch)
treeb85d0372a9aa1205a106c58f7a7f2e5ec80cdd31
parent06a5b8a8e4f01edbbcbc79c5e83f6b716deabbd0 (diff)
downloadaur-5f8fcfea70b6622bc516b486132d6bb84409144f.tar.gz
Fix build by adding missing dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
-rw-r--r--libxcrypt.patch29
3 files changed, 67 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1f03c80dbbb..13dffa28ef31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,23 @@
pkgbase = asleap
pkgdesc = Actively recover LEAP/PPTP passwords.
pkgver = 2.2
- pkgrel = 2
+ pkgrel = 3
url = http://www.willhackforsushi.com/Asleap.html
- arch = i686
arch = x86_64
license = GPL
depends = openssl
depends = libpcap
+ noextract = libxcrypt1.deb
+ noextract = libxcrypt-dev.deb
+ noextract = libxcrypt.patch
source = http://www.willhackforsushi.com/code/asleap/2.2/asleap-2.2.tgz
+ source = libxcrypt1.deb::http://mirrors.kernel.org/ubuntu/pool/universe/libx/libxcrypt/libxcrypt1_2.4-4_amd64.deb
+ source = libxcrypt-dev.deb::http://mirrors.kernel.org/ubuntu/pool/universe/libx/libxcrypt/libxcrypt-dev_2.4-4_amd64.deb
+ source = libxcrypt.patch
md5sums = a1d06729fb2addcc5b09bfc14f9b3173
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = asleap
diff --git a/PKGBUILD b/PKGBUILD
index 096eb2cfd917..20a52ec497fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,39 @@
pkgname=asleap
pkgver=2.2
-pkgrel=2
+pkgrel=3
pkgdesc='Actively recover LEAP/PPTP passwords.'
-arch=(i686 x86_64)
+arch=(x86_64)
license=(GPL)
url=http://www.willhackforsushi.com/Asleap.html
depends=(openssl libpcap)
source=(
http://www.willhackforsushi.com/code/asleap/$pkgver/asleap-$pkgver.tgz
+ libxcrypt1.deb::http://mirrors.kernel.org/ubuntu/pool/universe/libx/libxcrypt/libxcrypt1_2.4-4_amd64.deb
+ libxcrypt-dev.deb::http://mirrors.kernel.org/ubuntu/pool/universe/libx/libxcrypt/libxcrypt-dev_2.4-4_amd64.deb
+ libxcrypt.patch
+)
+noextract=(
+ libxcrypt1.deb
+ libxcrypt-dev.deb
+ libxcrypt.patch
)
md5sums=(
a1d06729fb2addcc5b09bfc14f9b3173
+ SKIP
+ SKIP
+ SKIP
)
+prepare() {
+ mkdir deb
+ ar p libxcrypt1.deb data.tar.xz | tar xJC deb
+ ar p libxcrypt-dev.deb data.tar.xz | tar xJC deb
+
+ cd $srcdir/asleap-$pkgver
+ patch --forward --strip=1 --input="${srcdir}/libxcrypt.patch"
+}
+
build() {
cd $srcdir/asleap-$pkgver
make
@@ -25,4 +45,10 @@ package() {
cd $srcdir/asleap-$pkgver
install -D asleap $pkgdir/usr/bin/asleap
install -D genkeys $pkgdir/usr/bin/genkeys
+
+ cd $srcdir/deb
+ install -dv $pkgdir/usr/lib
+ mv lib/libxcrypt.so.1.2.4 $pkgdir/usr/lib
+ ln -s $pkgdir/usr/lib/libxcrypt.so.1.2.4 $pkgdir/usr/lib/libxcrypt.so
+ ln -s $pkgdir/usr/lib/libxcrypt.so.1.2.4 $pkgdir/usr/lib/libxcrypt.so.1
}
diff --git a/libxcrypt.patch b/libxcrypt.patch
new file mode 100644
index 000000000000..1834bb4d5902
--- /dev/null
+++ b/libxcrypt.patch
@@ -0,0 +1,29 @@
+diff --unified --recursive --text --color asleap-2.2/Makefile asleap-2.2-new/Makefile
+--- asleap-2.2/Makefile 2007-07-13 20:00:58.000000000 -0500
++++ asleap-2.2-new/Makefile 2020-12-19 21:38:02.071555347 -0500
+@@ -7,10 +7,12 @@
+ # <dragorn> i think thats all anyone does
+ # <dragorn> make is a twisted beast
+ ##################################
+-LDLIBS = -lpcap -lcrypt
++LDLIBS = -lpcap -lxcrypt
+ CFLAGS = -pipe -Wall -D_LINUX -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I../../..
+ CFLAGS += -D_OPENSSL_MD4
+ LDLIBS += -lcrypto
++LDLIBS += -L"../deb/usr/lib"
++CFLAGS += -I"../deb/usr/include"
+ CFLAGS += -g3 -ggdb -g
+ PROGOBJ = asleap.o genkeys.o utils.o common.o sha1.o
+ PROG = asleap genkeys
+diff --unified --recursive --text --color asleap-2.2/utils.c asleap-2.2-new/utils.c
+--- asleap-2.2/utils.c 2007-07-13 20:00:58.000000000 -0500
++++ asleap-2.2-new/utils.c 2020-12-19 21:30:14.418336923 -0500
+@@ -27,7 +27,7 @@
+ #include <stdarg.h>
+ #include <string.h>
+ #include <stdint.h>
+-#include <crypt.h>
++#include <xcrypt.h>
+ #include <unistd.h>
+ #include <ctype.h>
+ #include <netinet/in.h> /* for ntohs() */