summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryan Horna2020-12-27 03:57:11 -0500
committerBryan Horna2020-12-27 03:57:11 -0500
commita4b7ba9ee5680624410c09d0806b93c3c6d42533 (patch)
tree23508fd2cfb5a60fa19508efc642f4fae449878c
parent116ea70dcfc9bc6ac1aca379f23c1c61acf9552a (diff)
downloadaur-a4b7ba9ee5680624410c09d0806b93c3c6d42533.tar.gz
Restore timeout functionality
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--fixtimeout.patch21
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d966ef4b049a..7580578f1f65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = asleap
pkgdesc = Actively recover LEAP/PPTP passwords.
pkgver = 2.2
- pkgrel = 5
+ pkgrel = 6
url = https://www.willhackforsushi.com/?page_id=41
arch = x86_64
arch = i686
@@ -15,8 +15,10 @@ pkgbase = asleap
noextract = libxcrypt-dev.deb
source = https://www.willhackforsushi.com/code/asleap/2.2/asleap-2.2.tgz
source = libxcrypt.patch
+ source = fixtimeout.patch
md5sums = a1d06729fb2addcc5b09bfc14f9b3173
md5sums = cb9cf76a3e7bee1e546ce9a982b0f912
+ md5sums = e0041a0a74428051cd7d19e0a7c5c5d8
source_x86_64 = libxcrypt1.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt1_2.4-4_amd64.deb
source_x86_64 = libxcrypt-dev.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt-dev_2.4-4_amd64.deb
md5sums_x86_64 = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f20c03d98440..e95c7902980e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,20 @@
pkgname=asleap
pkgver=2.2
-pkgrel=5
+pkgrel=6
pkgdesc="Actively recover LEAP/PPTP passwords."
arch=("x86_64" "i686" "armv6h" "armv7h" "aarch64")
url="https://www.willhackforsushi.com/?page_id=41"
license=("GPL")
depends=("libpcap" "openssl")
source=("https://www.willhackforsushi.com/code/$pkgname/$pkgver/$pkgname-$pkgver.tgz"
- "libxcrypt.patch")
+ "libxcrypt.patch"
+ "fixtimeout.patch")
noextract=("libxcrypt1.deb"
"libxcrypt-dev.deb")
md5sums=("a1d06729fb2addcc5b09bfc14f9b3173"
- "cb9cf76a3e7bee1e546ce9a982b0f912")
+ "cb9cf76a3e7bee1e546ce9a982b0f912"
+ "e0041a0a74428051cd7d19e0a7c5c5d8")
# Dynamically generate sources and skip sums
_arch=("amd64" "i386" "armel" "armhf" "arm64")
@@ -41,6 +43,7 @@ prepare() {
cd "$pkgname-$pkgver"
patch -Nup1 -i "$srcdir/libxcrypt.patch"
+ patch -Nup1 -i "$srcdir/fixtimeout.patch"
}
build() {
diff --git a/fixtimeout.patch b/fixtimeout.patch
new file mode 100644
index 000000000000..6be5f3decb6f
--- /dev/null
+++ b/fixtimeout.patch
@@ -0,0 +1,21 @@
+diff -Naur asleap-2.2/asleap.c asleap-2.2-new/asleap.c
+--- asleap-2.2/asleap.c 2008-05-28 10:36:21.000000000 -0500
++++ asleap-2.2-new/asleap.c 2020-12-27 03:50:06.417501493 -0500
+@@ -1395,7 +1395,7 @@
+ char *device, dictfile[255], dictidx[255], pcapfile[255];
+ struct asleap_data asleap;
+ struct stat dictstat, capturedatastat;
+- int findleaptimeout = 5;
++ int findleaptimeout = 0;
+ unsigned int findlpexchret = 0;
+ int ret=0;
+ extern int success;
+@@ -1605,7 +1605,7 @@
+
+ while (1) {
+
+- findlpexchret = findlpexch(&asleap, 0, offset);
++ findlpexchret = findlpexch(&asleap, findleaptimeout, offset);
+
+ if (findlpexchret == LEAPEXCHFOUND) {
+ printf("\nCaptured LEAP exchange information:\n");