summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:09:56 +0200
committerMaxime Gauduin2015-06-08 11:09:56 +0200
commit9ccbb13ac58b9c59ccbca94191e142d295d646d2 (patch)
tree0419cf114e181895ccd784c65f2b3be7f4d6dda1
downloadaur-9ccbb13ac58b9c59ccbca94191e142d295d646d2.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9da7dc1a1de3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = asmjit-git
+ pkgdesc = Complete x86/x64 JIT and Remote Assembler for C++
+ pkgver = r102.d7fc62d
+ pkgrel = 1
+ url = https://github.com/kobalicek/asmjit
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = git
+ depends = gcc-libs
+ source = git+https://github.com/kobalicek/asmjit.git
+ sha256sums = SKIP
+
+pkgname = asmjit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6b9e1156ba6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: perlawk <perlawk@yahoo.com.hk>
+# Contributor: xantares <xantares09@hotmail.com>
+
+pkgname=asmjit-git
+pkgver=r102.d7fc62d
+pkgrel=1
+pkgdesc='Complete x86/x64 JIT and Remote Assembler for C++'
+arch=('i686' 'x86_64')
+url='https://github.com/kobalicek/asmjit'
+license=('custom')
+depends=('gcc-libs')
+makedepends=('cmake' 'git')
+source=("git+https://github.com/kobalicek/asmjit.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cd ${pkgname%-*}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package () {
+ cd ${pkgname%-*}/build
+
+ make install DESTDIR="$pkgdir"
+
+ install -dm 755 "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -m 644 ../LICENSE.md "${pkgdir}"/usr/share/licenses/${pkgname}
+}
+
+# vim: ts=2 sw=2 et: