summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-03-22 14:27:01 +0100
committerAlexandre Bouvier2022-03-22 14:32:56 +0100
commitcbe002a3b65385231bd58e377e64b08117daa68b (patch)
tree5af1838f775ef6d3691049ee30871d04ba9c06b6
parent68c1f31bdab30fed5e0528635d2bcc9aa84d7e65 (diff)
downloadaur-cbe002a3b65385231bd58e377e64b08117daa68b.tar.gz
update to r398.21a31b8
* shared and static builds cannot be packaged together because their cmake config files are in conflict * update url, source and description * add more arch * add tests
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD85
2 files changed, 42 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 217c0bf3a108..15edd95341e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = asmjit-git
- pkgdesc = Complete x86/x64 JIT and Remote Assembler for C++
- pkgver = r162.bd0d261
+ pkgdesc = Machine code generation for C++
+ pkgver = r398.21a31b8
pkgrel = 1
- url = https://github.com/kobalicek/asmjit
+ url = https://asmjit.com/
+ arch = aarch64
+ arch = armv7h
+ arch = i486
arch = i686
+ arch = pentium4
arch = x86_64
- license = customi:zlib
+ license = ZLIB
makedepends = cmake
makedepends = git
depends = gcc-libs
- options = staticlibs
- source = git+https://github.com/kobalicek/asmjit.git
- sha256sums = SKIP
+ provides = asmjit=r398.21a31b8
+ provides = libasmjit.so
+ conflicts = asmjit
+ source = git+https://github.com/asmjit/asmjit.git
+ b2sums = SKIP
pkgname = asmjit-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 88765f77c52d..760e79c34dd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,70 +1,43 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: perlawk <perlawk@yahoo.com.hk>
# Contributor: xantares <xantares09@hotmail.com>
-
-pkgname=asmjit-git
-pkgver=r162.bd0d261
+_pkgname=asmjit
+pkgname=$_pkgname-git
+pkgver=r398.21a31b8
pkgrel=1
-pkgdesc='Complete x86/x64 JIT and Remote Assembler for C++'
-arch=('i686' 'x86_64')
-url='https://github.com/kobalicek/asmjit'
-license=('customi:zlib')
+pkgdesc="Machine code generation for C++"
+arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
+url="https://asmjit.com/"
+license=('ZLIB')
depends=('gcc-libs')
makedepends=('cmake' 'git')
-options=('staticlibs')
-source=('git+https://github.com/kobalicek/asmjit.git')
-sha256sums=('SKIP')
+provides=("$_pkgname=$pkgver" 'libasmjit.so')
+conflicts=("$_pkgname")
+source=("git+https://github.com/asmjit/$_pkgname.git")
+b2sums=('SKIP')
pkgver() {
- cd asmjit
-
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- sed 's/-fno-exceptions//g' -i asmjit/CMakeLists.txt
-
- cp -r asmjit asmjit-static
+build() {
+ cmake -S $_pkgname -B build \
+ -DASMJIT_NO_CUSTOM_FLAGS=ON \
+ -DASMJIT_TEST="$CHECKFUNC" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+ cmake --build build
}
-build () {
- cd asmjit
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr'
- make
-
- cd ../../asmjit-static
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DASMJIT_STATIC='TRUE'
- make
+check() {
+ ctest --test-dir build
}
-package () {
- cd asmjit/build
-
- make install DESTDIR="${pkgdir}"
-
- cd ../../asmjit-static/build
-
- make install DESTDIR="${pkgdir}"
-
- install -dm 755 "${pkgdir}"/usr/share/licenses/asmjit-git
- install -m 644 ../LICENSE.md "${pkgdir}"/usr/share/licenses/asmjit-git/
+package() {
+ # shellcheck disable=SC2154
+ DESTDIR="$pkgdir" cmake --install build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname $_pkgname/LICENSE.md
}
-
-# vim: ts=2 sw=2 et: