summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay2018-02-09 20:48:16 +0600
committerNikolay2018-02-09 20:48:16 +0600
commit1e4b99d4cce36b7a3559b407964dbbf9e5826035 (patch)
treef962450f5b6a754ca081321723e38e74d80fbb41
downloadaur-1e4b99d4cce36b7a3559b407964dbbf9e5826035.tar.gz
First Version
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD65
-rw-r--r--asofed.service9
-rw-r--r--boost-no-mt-suffix.patch11
-rw-r--r--use-system-rust.patch10
5 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd92a8317d50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Wed Feb 7 12:36:28 UTC 2018
+pkgbase = asofe
+ pkgdesc = Permissionless financial system employing zero-knowledge security
+ pkgver = 1.0.14
+ pkgrel = 2
+ url = https://asofe.org/
+ arch = x86_64
+ license = MIT
+ checkdepends = python
+ checkdepends = python2
+ checkdepends = python2-pyzmq
+ makedepends = boost
+ makedepends = cargo
+ makedepends = cmake
+ makedepends = git
+ makedepends = gmock
+ makedepends = python
+ makedepends = wget
+ depends = boost-libs
+ depends = libevent
+ depends = zeromq
+ source = git+https://github.com/TheLightSide/asofe.git#commit=e0015f873f3875e899418ce5870ebb4023aa6f1d
+ source = boost-no-mt-suffix.patch
+ source = use-system-rust.patch
+ source = asofed.service
+ sha512sums = SKIP
+ sha512sums = 370c9fff0c62fe1f77b9edee1af87dde087804e6a3b1eb9b2c27b49868e58ccf85a4814c813aea98c98a5c50533822b70338b57f3b3ced1adf02e5fa0c712c56
+ sha512sums = 575a78b2c54d99eeb9b63f921c605a34417d81506e1c3e6b927269306bd83da373c2d6d3b5d44cbf3198d03f0d47a17a445ffa69ab49348b394e947b4169d172
+ sha512sums = bfc39352e50078c7897ae3b8167f06d152f26c52dc7199ae952bad85b99a9da4f9d25d63edfe52291ad27b6e08b828c5db205eb0dc6091ec3fc75dc2b1bfca19
+
+pkgname = asofe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49f4157cb618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# $Id$
+# Maintainer: Nikolay Kuzin <develnk@gmail.com>
+
+pkgname=asofe
+pkgver=1.0.14
+_commit=88ee9402393643841643f24040b32be8dd47467e
+pkgrel=2
+pkgdesc='Permissionless financial system employing zero-knowledge security'
+arch=('x86_64')
+url='https://asofe.org/'
+license=('MIT')
+depends=('boost-libs' 'libevent' 'zeromq')
+makedepends=('boost' 'cargo' 'cmake' 'git' 'gmock' 'python' 'wget')
+checkdepends=('python' 'python2' 'python2-pyzmq')
+source=("git+https://github.com/TheLightSide/asofe.git#commit=${_commit}"
+ "boost-no-mt-suffix.patch"
+ "use-system-rust.patch"
+ 'asofed.service')
+sha512sums=('SKIP'
+ '370c9fff0c62fe1f77b9edee1af87dde087804e6a3b1eb9b2c27b49868e58ccf85a4814c813aea98c98a5c50533822b70338b57f3b3ced1adf02e5fa0c712c56'
+ '575a78b2c54d99eeb9b63f921c605a34417d81506e1c3e6b927269306bd83da373c2d6d3b5d44cbf3198d03f0d47a17a445ffa69ab49348b394e947b4169d172'
+ 'bfc39352e50078c7897ae3b8167f06d152f26c52dc7199ae952bad85b99a9da4f9d25d63edfe52291ad27b6e08b828c5db205eb0dc6091ec3fc75dc2b1bfca19')
+
+prepare() {
+ cd ${pkgname}
+
+ # Set gitattributes on src/clientversion.cpp
+ git archive --format=tar ${_commit} -- src/clientversion.cpp | tar -xf -
+
+ patch -Np1 -i ../boost-no-mt-suffix.patch
+ patch -Np1 -i ../use-system-rust.patch
+}
+
+build() {
+ cd ${pkgname}
+
+ HOST="$(./depends/config.guess)" BUILD="$(./depends/config.guess)" make -j8 -C ./depends/ V=1
+
+ CPPFLAGS="${CPPFLAGS} -I$PWD/depends/${CARCH}-unknown-linux-gnu/include"
+ LDFLAGS="${LDFLAGS} -L${PWD}/depends/${CARCH}-unknown-linux-gnu/lib -L${PWD}/depends/x86_64-unknown-linux-gnu/lib64"
+
+ ./autogen.sh
+ depends_prefix="${PWD}/depends/x86_64-unknown-linux-gnu" ./configure --prefix=/usr
+ make -i -j8
+}
+
+check() {
+ cd ${pkgname}
+ # ./zcutil/fetch-params.sh
+ # ./qa/zcash/full_test_suite.py
+}
+
+package() {
+ cd ${pkgname}
+
+ make DESTDIR="${pkgdir}" install
+
+ for ext in '-cli' '-tx' 'd'; do
+ install -Dm644 contrib/asofe${ext}.bash-completion \
+ "${pkgdir}"/usr/share/bash-completion/completions/asofe${ext}
+ done
+
+ install -Dm644 -t "${pkgdir}"/usr/lib/systemd/user ../asofed.service
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING
+}
diff --git a/asofed.service b/asofed.service
new file mode 100644
index 000000000000..43f72aabd913
--- /dev/null
+++ b/asofed.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Asofe daemon
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/asofed
+
+[Install]
+WantedBy=default.target \ No newline at end of file
diff --git a/boost-no-mt-suffix.patch b/boost-no-mt-suffix.patch
new file mode 100644
index 000000000000..c71216d11df1
--- /dev/null
+++ b/boost-no-mt-suffix.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -720,7 +720,7 @@
+ AX_CHECK_COMPILE_FLAG([-fno-strict-aliasing],[CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"])
+ AX_CHECK_COMPILE_FLAG([-Wno-builtin-declaration-mismatch],[CXXFLAGS="$CXXFLAGS -Wno-builtin-declaration-mismatch"],,[[$CXXFLAG_WERROR]])
+
+-LIBZCASH_LIBS="-lgmp -lgmpxx -lboost_system-mt -lcrypto -lsodium $RUST_LIBS"
++LIBZCASH_LIBS="-lgmp -lgmpxx -lboost_system -lcrypto -lsodium $RUST_LIBS"
+
+ AC_MSG_CHECKING([whether to build bitcoind])
+ AM_CONDITIONAL([BUILD_BITCOIND], [test x$build_bitcoind = xyes]) \ No newline at end of file
diff --git a/use-system-rust.patch b/use-system-rust.patch
new file mode 100644
index 000000000000..5d26982c9331
--- /dev/null
+++ b/use-system-rust.patch
@@ -0,0 +1,10 @@
+--- a/depends/packages/librustzcash.mk
++++ b/depends/packages/librustzcash.mk
+@@ -5,7 +5,6 @@
+ $(package)_download_file=$($(package)_git_commit).tar.gz
+ $(package)_sha256_hash=a5760a90d4a1045c8944204f29fa2a3cf2f800afee400f88bf89bbfe2cce1279
+ $(package)_git_commit=91348647a86201a9482ad4ad68398152dc3d635e
+-$(package)_dependencies=rust
+
+ define $(package)_build_cmds
+ cargo build --release \ No newline at end of file