summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordevelnk2018-06-15 18:58:20 +0300
committerdevelnk2018-06-15 19:20:18 +0300
commitb191f58ea6baf1a76aa2603f46f233367dec410f (patch)
tree5eece38b246b795e07d4c03666eac4c38f58062c
parentb64b342c780256602ea6a0e73627a0b50fa7bcbb (diff)
downloadaur-b191f58ea6baf1a76aa2603f46f233367dec410f.tar.gz
Updated to 1.0.16
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--boost-no-mt-suffix.patch11
-rw-r--r--use-system-rust.patch10
4 files changed, 6 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a6490ee48bc..61408bbacf61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asofe
pkgdesc = Permissionless financial system employing zero-knowledge security
- pkgver = 1.0.15
+ pkgver = 1.0.16
pkgrel = 1
url = https://asofe.org/
arch = x86_64
@@ -8,23 +8,17 @@ pkgbase = asofe
checkdepends = python
checkdepends = python2
checkdepends = python2-pyzmq
- makedepends = boost
makedepends = cargo
makedepends = cmake
makedepends = git
makedepends = gmock
makedepends = python
makedepends = wget
- depends = boost-libs
depends = libevent
depends = zeromq
- source = git+https://github.com/TheLightSide/asofe.git#commit=54a4d90d8f57e5cf2a2fa3b4f868b4fd5518aa60
- source = boost-no-mt-suffix.patch
- source = use-system-rust.patch
+ source = git+https://github.com/TheLightSide/asofe.git#commit=2243f7994ef7af4d82d49efd679c423f6a78017c
source = asofed.service
sha512sums = SKIP
- sha512sums = 370c9fff0c62fe1f77b9edee1af87dde087804e6a3b1eb9b2c27b49868e58ccf85a4814c813aea98c98a5c50533822b70338b57f3b3ced1adf02e5fa0c712c56
- sha512sums = 575a78b2c54d99eeb9b63f921c605a34417d81506e1c3e6b927269306bd83da373c2d6d3b5d44cbf3198d03f0d47a17a445ffa69ab49348b394e947b4169d172
sha512sums = bfc39352e50078c7897ae3b8167f06d152f26c52dc7199ae952bad85b99a9da4f9d25d63edfe52291ad27b6e08b828c5db205eb0dc6091ec3fc75dc2b1bfca19
pkgname = asofe
diff --git a/PKGBUILD b/PKGBUILD
index 7c28b88f72e8..ae35f6752442 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,19 @@
# Maintainer: Nikolay Kuzin <develnk@gmail.com>
pkgname=asofe
-pkgver=1.0.15
-_commit=54a4d90d8f57e5cf2a2fa3b4f868b4fd5518aa60
+pkgver=1.0.16
+_commit=2243f7994ef7af4d82d49efd679c423f6a78017c
pkgrel=1
pkgdesc='Permissionless financial system employing zero-knowledge security'
arch=('x86_64')
url='https://asofe.org/'
license=('MIT')
-depends=('boost-libs' 'libevent' 'zeromq')
-makedepends=('boost' 'cargo' 'cmake' 'git' 'gmock' 'python' 'wget')
+depends=('libevent' 'zeromq')
+makedepends=('cargo' 'cmake' 'git' 'gmock' 'python' 'wget')
checkdepends=('python' 'python2' 'python2-pyzmq')
source=("git+https://github.com/TheLightSide/asofe.git#commit=${_commit}"
- "boost-no-mt-suffix.patch"
- "use-system-rust.patch"
'asofed.service')
sha512sums=('SKIP'
- '370c9fff0c62fe1f77b9edee1af87dde087804e6a3b1eb9b2c27b49868e58ccf85a4814c813aea98c98a5c50533822b70338b57f3b3ced1adf02e5fa0c712c56'
- '575a78b2c54d99eeb9b63f921c605a34417d81506e1c3e6b927269306bd83da373c2d6d3b5d44cbf3198d03f0d47a17a445ffa69ab49348b394e947b4169d172'
'bfc39352e50078c7897ae3b8167f06d152f26c52dc7199ae952bad85b99a9da4f9d25d63edfe52291ad27b6e08b828c5db205eb0dc6091ec3fc75dc2b1bfca19')
prepare() {
@@ -26,9 +22,6 @@ prepare() {
# Set gitattributes on src/clientversion.cpp
git archive --format=tar ${_commit} -- src/clientversion.cpp | tar -xf -
-
- patch -Np1 -i ../boost-no-mt-suffix.patch
- patch -Np1 -i ../use-system-rust.patch
}
build() {
diff --git a/boost-no-mt-suffix.patch b/boost-no-mt-suffix.patch
deleted file mode 100644
index c71216d11df1..000000000000
--- a/boost-no-mt-suffix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -720,7 +720,7 @@
- AX_CHECK_COMPILE_FLAG([-fno-strict-aliasing],[CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"])
- AX_CHECK_COMPILE_FLAG([-Wno-builtin-declaration-mismatch],[CXXFLAGS="$CXXFLAGS -Wno-builtin-declaration-mismatch"],,[[$CXXFLAG_WERROR]])
-
--LIBZCASH_LIBS="-lgmp -lgmpxx -lboost_system-mt -lcrypto -lsodium $RUST_LIBS"
-+LIBZCASH_LIBS="-lgmp -lgmpxx -lboost_system -lcrypto -lsodium $RUST_LIBS"
-
- AC_MSG_CHECKING([whether to build bitcoind])
- AM_CONDITIONAL([BUILD_BITCOIND], [test x$build_bitcoind = xyes]) \ No newline at end of file
diff --git a/use-system-rust.patch b/use-system-rust.patch
deleted file mode 100644
index 5d26982c9331..000000000000
--- a/use-system-rust.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/depends/packages/librustzcash.mk
-+++ b/depends/packages/librustzcash.mk
-@@ -5,7 +5,6 @@
- $(package)_download_file=$($(package)_git_commit).tar.gz
- $(package)_sha256_hash=a5760a90d4a1045c8944204f29fa2a3cf2f800afee400f88bf89bbfe2cce1279
- $(package)_git_commit=91348647a86201a9482ad4ad68398152dc3d635e
--$(package)_dependencies=rust
-
- define $(package)_build_cmds
- cargo build --release \ No newline at end of file