summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commit3ccce9703bec5fd7e755e3d0c5da7b5ee4577bf1 (patch)
tree97ed92ae1f43807961d300e1e8d6a26ac6a14577
parent0664882307f2bc64b859e0881ba94881871cc766 (diff)
downloadaur-3ccce9703bec5fd7e755e3d0c5da7b5ee4577bf1.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD53
2 files changed, 35 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6f66c02a255..f6949ec4f905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,20 @@
# Generated by mksrcinfo v8
-# Wed Oct 12 21:46:55 UTC 2016
+# Wed Mar 27 09:15:56 UTC 2019
pkgbase = aspcud
pkgdesc = Solver for package dependencies
- pkgver = 1.9.1
- pkgrel = 1
- url = http://potassco.sourceforge.net/
+ pkgver = 1.9.4
+ pkgrel = 4
+ url = https://potassco.org/aspcud
arch = x86_64
- arch = i686
- arch = armv6h
- arch = armv7h
- groups = potassco
license = GPL3
makedepends = boost
makedepends = cmake
+ makedepends = git
+ makedepends = ninja
makedepends = re2c
- depends = clasp>=2.1.3
- depends = clingo>=5.0.0
- conflicts = aspcud-svn
- source = http://downloads.sourceforge.net/project/potassco/aspcud/1.9.1/aspcud-1.9.1-source.tar.gz
- sha1sums = db1ce85814699fb77aff41f4f6df0721d6851756
+ depends = clingo
+ source = git+https://github.com/potassco/aspcud#tag=v1.9.4
+ md5sums = SKIP
pkgname = aspcud
diff --git a/PKGBUILD b/PKGBUILD
index 0dc9df7af339..c282e7a2cd8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,35 @@
-# Maintainer: Vincent Bernardoff <vb@luminar.eu.org>
+# Maintainer:
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
pkgname=aspcud
-groups=('potassco')
-pkgver=1.9.1
-pkgrel=1
-pkgdesc="Solver for package dependencies"
-arch=('x86_64' 'i686' 'armv6h' 'armv7h')
-url="http://potassco.sourceforge.net/"
+pkgver=1.9.4
+pkgrel=4
+pkgdesc='Solver for package dependencies'
+arch=('x86_64')
+url='https://potassco.org/aspcud'
license=('GPL3')
-depends=('clasp>=2.1.3' 'clingo>=5.0.0')
-conflicts=('aspcud-svn')
-makedepends=('boost' 'cmake' 're2c')
-source=(
- "http://downloads.sourceforge.net/project/potassco/${pkgname}/${pkgver}/${pkgname}-${pkgver}-source.tar.gz"
-)
-sha1sums=(db1ce85814699fb77aff41f4f6df0721d6851756)
+makedepends=('boost' 'cmake' 'git' 'ninja' 're2c')
+depends=('clingo')
+source=("git+https://github.com/potassco/$pkgname#tag=v$pkgver")
+md5sums=('SKIP')
build() {
- cd "$srcdir/$pkgname-$pkgver-source"
- mkdir -p build/release
- cd build/release
- cmake \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DCUDF2LP_LOC=cudf2lp \
- -DGRINGO_LOC=gringo \
- -DCLASP_LOC=clasp \
- -DCMAKE_BUILD_TYPE=Release ../..
- make
+ mkdir -p build
+ cd build
+ cmake "../$pkgname" \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_LIBDIR:PATH=lib \
+ -DCUDF2LP_LOC=cudf2lp \
+ -DGRINGO_LOC=gringo \
+ -DCLASP_LOC=clasp \
+ -DCMAKE_BUILD_TYPE=Release \
+ -GNinja
+ ninja
}
package() {
- cd "$srcdir/$pkgname-$pkgver-source"
- cd build/release
- make DESTDIR=${pkgdir} install
+ DESTDIR="$pkgdir" ninja -C build install
}
+
+# vim: ts=2 sw=2 et: