summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-11-03 07:58:37 +0800
committerChocobo12018-11-03 08:09:27 +0800
commit2ba3a7f3600173c7c6072f63b66b3d31fcead341 (patch)
tree613d573744f15cadc451fc5afb1e4e4c0d53cf0c
downloadaur-2ba3a7f3600173c7c6072f63b66b3d31fcead341.tar.gz
newpkg: aspell 0.60.7.20110707.r19.gb2e2b25-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8e601065c11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = aspell-git
+ pkgdesc = Free and Open Source spell checker
+ pkgver = 0.60.7.20110707.r19.gb2e2b25
+ pkgrel = 1
+ url = http://aspell.net/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = ncurses
+ optdepends = perl: to import old dictionaries
+ provides = aspell
+ conflicts = aspell
+ options = staticlibs
+ source = git+https://git.savannah.gnu.org/git/aspell.git
+ sha256sums = SKIP
+
+pkgname = aspell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a1afd8f1905
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=aspell-git
+pkgver=0.60.7.20110707.r19.gb2e2b25
+pkgrel=1
+pkgdesc="Free and Open Source spell checker"
+arch=('i686' 'x86_64')
+url="http://aspell.net/"
+license=('LGPL')
+depends=('ncurses')
+makedepends=('git')
+optdepends=('perl: to import old dictionaries')
+provides=('aspell')
+conflicts=('aspell')
+options=('staticlibs')
+source=("git+https://git.savannah.gnu.org/git/aspell.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "aspell"
+
+ git describe --long --tags | sed 's/^rel-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "aspell"
+
+ PERL_USE_UNSAFE_INC=1 ./autogen
+ ./configure \
+ --prefix="/usr" --sysconfdir="/etc" \
+ --enable-static
+ make
+}
+
+package() {
+ cd "aspell"
+
+ make DESTDIR="$pkgdir" install
+}