summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-01-23 09:06:59 +0100
committeraksr2016-01-23 09:06:59 +0100
commit2abe2d821dd8be924e53f1242986491d7844f9b5 (patch)
treefdd77b7e08aeb8d6c58091ee6ff293a02c16522b
downloadaur-2abe2d821dd8be924e53f1242986491d7844f9b5.tar.gz
Start.
-rw-r--r--.SRCINFO19
-rw-r--r--ChangeLog87
-rw-r--r--PKGBUILD46
3 files changed, 152 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d37684bf2433
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Jan 23 08:06:58 UTC 2016
+pkgbase = aspic
+ pkgdesc = A program for turning a textual description of a line drawing into PostScript or Scalable Vector Graphics.
+ pkgver = 1.05
+ pkgrel = 1
+ url = http://people.ds.cam.ac.uk/ph10/
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ provides = aspic
+ source = ftp://ftp.csx.cam.ac.uk/pub/software/wordprocessing/unix/aspic/aspic-1.05.tar.gz
+ md5sums = 71dab77949d7c6c0920f1e8bfc19e96d
+ sha1sums = d7e83fcd0a0322e2fcb263485b3f82f6bb95e4d9
+ sha256sums = 09ca0bbf6fbdf12447988e33bdd259038b9184f1b187e8d3f552cbe9924cb6b3
+
+pkgname = aspic
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..a0836648d7d2
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,87 @@
+Change Log for Aspic
+--------------------
+
+Version 1.05 04 March 2008
+---------------------------
+
+ 1. Tidied Makefile so that it shows only a short line for each compiled file.
+
+ 2. Added the -testing feature to avoid the version identification in the PS
+ and SVG output, thus making it easier to maintain the tests.
+
+ 3. Text strings associated with non-horizontal lines are moved 3 points to
+ the right by default - they were hitting vertical lines. Text strings
+ associated with arcs are moved 6 points to the right by default for the
+ same reason.
+
+ 4. When computing the bounding box of a picture, a rough guess at the size of
+ a string is now made, in order to take into account strings that stick out
+ out of the sides of a picture. Previously, strings were ignored when
+ computing boundinb boxes, leading to very bad values in some cases.
+ However, since Aspic doesn't actually process strings, the new code is just
+ a heuristic guess, though it seems to do a reasonable job.
+
+ 5. SVG output was not including strings associated with invisible lines.
+
+ 6. Improve vertical positioning of multiple strings when fonts of sizes
+ other than the default 12 points are used. The "textdepth" and "fontdepth"
+ parameters are now minima. When multiple lines of text are printed, if the
+ font size is greater than the textdepth setting, the larger size is used.
+ Similarly, if half the font size is greater than the fontdepth setting, it
+ is used. This is all heuristical, since Aspic doesn't really process text.
+
+ 7. Fix some uninitialized values bugs (found by valgrind).
+
+ 8. Change string character handling to recognize UTF-8 characters and
+ encodings using the &...; mechanism.
+
+ 9. Add the -tr option to translate quotes and en-dashes.
+
+
+Version 1.04 20 January 2008
+-----------------------------
+
+ 1. Fixed a bug that caused invisible boxes and ellipses not to be filled if
+ a filling colour was defined. I think the fix for 1.01 below broke it.
+
+
+Version 1.03 09 January 2008
+-----------------------------
+
+ 1. Fixed a bug that caused the wrong colour to be used in PostScript output in
+ certain cases for items following an arrow that was associated with
+ coloured text.
+
+
+Version 1.02 26 September 2007
+-------------------------------
+
+ 1. Added the "include" facility.
+
+ 2. The "level" facility wasn't working properly for PostScript output.
+
+ 3. Add the ability to colour text.
+
+
+Version 1.01 06 June 2007
+--------------------------
+
+ 1. PostScript output was going wrong for invisible boxes and lines that had
+ attached text strings.
+
+
+Version 1.00 28 December 2004
+------------------------------
+
+ 1. Added the "redraw" facility for use with SGCAL and sgpoint.
+
+
+Version 0.09 15 December 2004
+------------------------------
+
+ 1. Separated Aspic from the SGCAL command bundle and made it freestanding.
+ Abolished the separate configuration file, and instead implemented three
+ separate output modules for PostScript, SVG, and SGCAL output. Revised the
+ command interface.
+
+*** End ***
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5db5c42925d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=aspic
+pkgver=1.05
+pkgrel=1
+epoch=
+pkgdesc="A program for turning a textual description of a line drawing into PostScript or Scalable Vector Graphics."
+arch=('i686' 'x86_64')
+url="http://people.ds.cam.ac.uk/ph10/"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+optdepends=()
+checkdepends=()
+provides=('aspic')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=ChangeLog
+source=("ftp://ftp.csx.cam.ac.uk/pub/software/wordprocessing/unix/$pkgname/$pkgname-$pkgver.tar.gz")
+noextract=()
+options=()
+md5sums=('71dab77949d7c6c0920f1e8bfc19e96d')
+sha1sums=('d7e83fcd0a0322e2fcb263485b3f82f6bb95e4d9')
+sha256sums=('09ca0bbf6fbdf12447988e33bdd259038b9184f1b187e8d3f552cbe9924cb6b3')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver/testing"
+ #./RunTests
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make BINDIR=$pkgdir/usr/bin DATADIR=$pkgdir/usr/share/$pkgname MANDIR=$pkgdir/usr/share/man install
+ install -Dm644 doc/aspic.pdf $pkgdir/usr/share/doc/$pkgname/aspic.pdf
+ install -Dm644 LICENCE $pkgdir/usr/share/licenses/$pkgname/LICENCE
+}
+