summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2019-10-05 19:43:07 +0100
committerGr3q2019-10-05 19:43:07 +0100
commit52a0c2f3cb9a8d6b4f1001ab301dd8bed7f0b373 (patch)
tree624793b3a276f2e49115f5cd0ee9e9989a25f94f
downloadaur-52a0c2f3cb9a8d6b4f1001ab301dd8bed7f0b373.tar.gz
Added PKGBUILD and SRCINFO
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD27
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1872afe5c04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = aspnet-runtime-2.1
+ pkgdesc = The ASP.NET Core runtime version 2.1
+ pkgver = 2.1.13
+ pkgrel = 1
+ url = https://www.microsoft.com/net/core
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = clang
+ makedepends = cmake
+ makedepends = curl
+ makedepends = git
+ makedepends = lldb
+ makedepends = llvm
+ makedepends = lttng-ust
+ options = staticlibs
+ source_x86_64 = https://download.visualstudio.microsoft.com/download/pr/88fdaf6f-08ea-4d1c-856d-60f78a7d733a/2e70e89c45dc9a8d701b544edc2bb5a1/aspnetcore-runtime-2.1.13-linux-x64.tar.gz
+ sha512sums_x86_64 = 1d73b177782f6ae593dd56078d479d879dd470324113eb5a8a3ddeb12dbdcd6b0c0ee0fc722c8106c5117fc08d14a44f2f6fd3a47319df08ec1eb74af8a69c22
+ source_armv7h = https://download.visualstudio.microsoft.com/download/pr/39d580d6-da0b-42e3-9bbe-3fd2efec71ac/594ae2dde78da0e8b9e1cc7476cee470/aspnetcore-runtime-2.1.13-linux-arm.tar.gz
+ sha512sums_armv7h = 8d41a285e30733303b0a92a0d83c65a534597be46da280d60a2f759dff90b6e9d1222002d0c32cbe02856e0d3fe2e37d111b370cc30d35b162cc3c483d512744
+
+pkgname = aspnet-runtime-2.1
+ pkgdesc = The ASP.NET Core runtime version 2.1
+ arch = x86_64
+ arch = armv7h
+ depends = dotnet-runtime=2.1.13
+ provides = aspnet-runtime=2.1.13
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78ce6b824603
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Attila Greguss <floyd0122[at]gmail[dot]com>
+
+pkgname=('aspnet-runtime-2.1')
+pkgver=2.1.13
+pkgrel=1
+pkgdesc='The ASP.NET Core runtime version 2.1'
+arch=('x86_64' 'armv7h')
+url='https://www.microsoft.com/net/core'
+license=('MIT')
+makedepends=(
+ 'clang' 'cmake' 'curl' 'git' 'lldb' 'llvm' 'lttng-ust' )
+options=('staticlibs')
+source_armv7h=('https://download.visualstudio.microsoft.com/download/pr/39d580d6-da0b-42e3-9bbe-3fd2efec71ac/594ae2dde78da0e8b9e1cc7476cee470/aspnetcore-runtime-2.1.13-linux-arm.tar.gz')
+source_x86_64=('https://download.visualstudio.microsoft.com/download/pr/88fdaf6f-08ea-4d1c-856d-60f78a7d733a/2e70e89c45dc9a8d701b544edc2bb5a1/aspnetcore-runtime-2.1.13-linux-x64.tar.gz')
+sha512sums_armv7h=('8d41a285e30733303b0a92a0d83c65a534597be46da280d60a2f759dff90b6e9d1222002d0c32cbe02856e0d3fe2e37d111b370cc30d35b162cc3c483d512744')
+sha512sums_x86_64=('1d73b177782f6ae593dd56078d479d879dd470324113eb5a8a3ddeb12dbdcd6b0c0ee0fc722c8106c5117fc08d14a44f2f6fd3a47319df08ec1eb74af8a69c22')
+
+package() {
+ arch=('x86_64' 'armv7h')
+ pkgdesc='The ASP.NET Core runtime version 2.1'
+ depends=('dotnet-runtime=2.1.13')
+ provides=("aspnet-runtime=${pkgver%+*}")
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
+ ln -s dotnet-host-2.1 "${pkgdir}"/usr/share/licenses/aspnet-runtime-2.1
+}