summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2013-08-09 17:10:40 +0200
committerHyacinthe Cartiaux2015-06-08 14:25:26 +0200
commit32171a03ab6d3e08a1a750970e32c954d2b9a037 (patch)
treed0709ad0e4c91a9e85ec7eb6a8db98e34a65766f
downloadaur-32171a03ab6d3e08a1a750970e32c954d2b9a037.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44b171647268
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = asr-manpages
+ pkgdesc = A set of humorous manual pages developed on alt.sysadmin.recovery
+ pkgver = 1.3
+ pkgrel = 5
+ url = http://debian.org/
+ arch = any
+ license = custom
+ source = http://ftp.debian.org/debian/pool/main/a/asr-manpages/asr-manpages_1.3.orig.tar.gz
+ source = http://ftp.debian.org/debian/pool/main/a/asr-manpages/asr-manpages_1.3-6.diff.gz
+ md5sums = ee77b619e01a2d841a45469708d90631
+ md5sums = 9608fb9ee121a278bf4cac5fc6dae267
+
+pkgname = asr-manpages
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25ec088d36f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux at free.fr>
+# Contributor: Arkham <arkham at archlinux dot us>
+# Contributor: StaCk <proc.null at gmail dot com>
+
+pkgname=asr-manpages
+pkgver=1.3
+pkgrel=5
+pkgdesc="A set of humorous manual pages developed on alt.sysadmin.recovery"
+arch=('any')
+url="http://debian.org/"
+license=('custom')
+source=(http://ftp.debian.org/debian/pool/main/a/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/a/${pkgname}/${pkgname}_${pkgver}-6.diff.gz)
+md5sums=('ee77b619e01a2d841a45469708d90631'
+ '9608fb9ee121a278bf4cac5fc6dae267')
+
+build() {
+ cd $srcdir
+
+ # Apply the patch
+ patch -p0 -i ${pkgname}_$pkgver-6.diff || return 1
+
+ # Rename the manpages to man6
+ cd $pkgname-$pkgver.orig
+ for f in *.[0-57-9]fun ; do
+ mv $f ${f/.?fun/.6fun}
+ done
+}
+
+package() {
+ install -d $pkgdir/usr/share/man/man6/
+ install -m 644 $srcdir/$pkgname-$pkgver.orig/*.6fun \
+ $pkgdir/usr/share/man/man6/
+
+ # Install the license
+ install -Dm 644 $srcdir/$pkgname-$pkgver.orig/debian/copyright \
+ $pkgdir/usr/share/licenses/$pkgname/copyright
+}